1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Odd coolant temperature issue.

Discussion in 'A4/S4 forum(B5 Chassis)' started by TED7, Aug 5, 2013.

  1. TED7
    Offline

    TED7 Couldn't Find Reverse Gear

    Joined:
    Mar 12, 2013
    Messages:
    37
    Likes Received:
    2
    [Aug 5, 2013]
    Afternoon all.

    Since I got my S4 I have had a low coolant temperature on cold days (which I didn't notice when I bought it). On snowy days, the dial rarely moved above 70 degrees. If I left the car sitting still (i.e. with no air flow through the rad), it would go up to 90 and hold steady. Leaving me to believe the thermostat was stuck open.

    I have accepted this, and have been living with it.

    However, I recently discovered the diagnostic mode on the climate control panel and when I set this to 51c, which I am led to believe is engine coolant temperature, the readout starts just above ambient when I start the car, goes up slowly and after around 2 miles is 90, where it holds steady, even at 70mph (14 degrees ambient today, in rain). The dash readout didn't move from 60 until I stopped at home where it moved to 65 before I turned the engine off.

    Do B5s have 2 different sensors for coolant, one in the engine and one in the climate control heat exchanger, or does the climate control get this temp from the ECU (like it receives revs and vehicle speed) and I have a buggy dash? It may be worth noting that the DIS is also temperamental, not in the usual missing pixels way, sometimes it's just faded in patches and doesn't really light up.
    Last edited: Aug 5, 2013
    #1
  2. Ads

    Ads

    [Sep 30, 2014]

  3. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,614
    Likes Received:
    318
    [Aug 5, 2013]
    51c isnt the coolant temp, its some sort of virtual value that acts like the coolant temp but isnt. Use 49c instead.

    And yes, the B5 does have two sensors, but thats not why your 51c is reporting the wrong thing!
    #2
  4. TED7
    Offline

    TED7 Couldn't Find Reverse Gear

    Joined:
    Mar 12, 2013
    Messages:
    37
    Likes Received:
    2
    [Aug 5, 2013]
    Ha! That's not what I wanted to hear but thanks anyway. 49c follows the dial +/- a bit.
    #3
  5. audi-a6
    Offline

    audi-a6 Member

    Joined:
    Aug 9, 2011
    Messages:
    494
    Likes Received:
    18
    [Aug 5, 2013]
    i had same problem, if driving along temp gauge would hardley move then if im sat at lights temp gauge would creep up....... changed thermostat and problem was fixed
    #4

Share This Page