1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

O/S Doors opened not recognised!!

lockie2002 Oct 2, 2011

  1. lockie2002

    lockie2002 In the Fast Lane!

    30
    0
    6
    Just wondered if anyone has had this problem before and how do you solve it, when i open the doors on the drivers side my car doesnt recognise that they are open so if ive just unlocked the car and left the door open for a period of time without putting the ignition on it will lock itself also when ignition is on it doesn't show them open on the display. Passenger side all fine!

    What could it be??

    Cheers Steve
     
  2. swarcup

    swarcup Well-Known Member

    1,326
    40
    48
    Door lock microswitches jammed or broken i would say. There are a few that say a squirt of wd40 in the right place will sort it if its jammed.
     
  3. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    mine done similar thing m8 check the wiring in the rubber boot.... between post and door mine broke inside the boot seems popular issue
     
  4. lockie2002

    lockie2002 In the Fast Lane!

    30
    0
    6
    ok will check these cheers where is the microswitch situated?? is it common to happen on both front and rear door at the same time or overtime don't actually know how long its been like this only had the car 2 months!

    Thanks again
     
  5. quattro tony

    quattro tony Member

    167
    0
    16
    Does the interior light come on when you open the doors on the drivers side, worth checking the stuffs mentioned above
     
  6. lockie2002

    lockie2002 In the Fast Lane!

    30
    0
    6
    no they don't come on bud
     
  7. quattro tony

    quattro tony Member

    167
    0
    16
    It seems odd that both the drivers and the rear door is doing this if they have both gone fautly at the same time, def worth checking the wiring and lube up the locks,Im pretty sure the micro switch is located inside the door lock/latch assembly, someone can correct me if i am wrong. Also do the doors lock and unlock ok?
     
  8. lockie2002

    lockie2002 In the Fast Lane!

    30
    0
    6
    Yeah doors all lock fine with no issues just no interior light or door open warning on the DIS!!

    Cheers
     
  9. choimaloy

    choimaloy Member

    111
    0
    16
    Mine has this problem to but only on the passenger front door do you think it could just be the wiring loom,if not where do you squirt the wd40.
     
  10. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    microswitch is in the lock mechanism itself the little plastic pin wears down over time stopping the contact, my loom broke causing this but only my drivers side front door not the rear aswell unless they linked of the power supply, i noticed mine as when i opened the door wide open my electric window stopped working and shiut the doors was working fine again
     
  11. lockie2002

    lockie2002 In the Fast Lane!

    30
    0
    6
    The drivers door is intermittent now so I presume this is the microswith as when I bang near the latch it recognises it's open but the driver rear is still not recognised, will have a play at the weekend!

    Thanks for all your comments, really big help

    Cheers:thumbsup:
     
  12. choimaloy

    choimaloy Member

    111
    0
    16
    Hi still got a problem with my passenger front door,the door doesn't lock while all the others do,no interior light doesn't come on when open and it doesn't show up on dis when open either.funny thing is the window switch lights up and the window works but the red light on the edge of the doesn't light up when open.ive checked the door loom for breaks and is clear,has anyone got a clue on what it could be.
     
  13. Turkster

    Turkster Bro.Paul 2.5TDI Quattro Sport

    2,796
    47
    48
    iv got a set of lock micro mechanisums if your in need, :hi:
     
  14. choimaloy

    choimaloy Member

    111
    0
    16
    Hi turkster do you think that's the problem,how much for the mechanism mate.
     
  15. stu_m

    stu_m Well-Known Member VCDS Map User

    1,440
    38
    48
    i would check the wiring first its free to check!!

    my boot did the same not so long back and it was the wiring
     
  16. choimaloy

    choimaloy Member

    111
    0
    16
    Checked the wiring all is good,need to know else it could be.
     
  17. stu_m

    stu_m Well-Known Member VCDS Map User

    1,440
    38
    48
    either the wiring or the switch i recon so next would be switch
     
  18. Turkster

    Turkster Bro.Paul 2.5TDI Quattro Sport

    2,796
    47
    48
    try and count how many times that doors been open and closed and then add the slam's over the amont of years of service its given and then you can see why the micro switchies are busted, :hi: PM sent !
     
    Last edited: Feb 28, 2012
  19. choimaloy

    choimaloy Member

    111
    0
    16
    Cheers turkster,sent you pm.
     

Share This Page