1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No DIS, clock lights flickering, no speedo/rev

Discussion in 'A3/S3/Sportback (8P Chassis)' started by GuyJ, Feb 27, 2013.

  1. GuyJ
    Offline

    GuyJ Member

    Joined:
    Oct 25, 2012
    Messages:
    59
    Likes Received:
    13
    [Feb 27, 2013]
    Well....last night I locked my at up went to bed, woke up, went outside and I left my blooming window open a little :-(
    It was super cold last night. So, I jumped in and shut the window. I have a van and drive that to work. So came home tonight to find that I have no DIS, Speedo, revs, Dash lights are flickering occasionally. ESP light up, steering light and airbag.

    I know I will have to get it scanned :-( just wondering if anyone has any insight.
    I have the car running just now to see if its just condensation or something silly :-/
    panicking a little!

    Thanks guys
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Feb 27, 2013]
    Remove the cluster, put it in the airing cupboard or on a rad over night, then test.

    There will be lights on when you plug back in which should go out when you drive the car.

    The trim directly below the cluster does pull back with some minor forcewith finger/thumb on both sides, 2 size 8 bolts need removing, magnetic tool better, so they dont fall down into steering column, then lift cluster out & pull the bottom up & over round the steering wheel to see the connector, then you need to pull the latching clip over to make the connector open & lift out.
    #2
  4. GuyJ
    Offline

    GuyJ Member

    Joined:
    Oct 25, 2012
    Messages:
    59
    Likes Received:
    13
    [Mar 5, 2013]
    @NHN i put the car in a garage with windows all down space heater on and it seemed to work. I disconnected the battery for 20 mins or so also. Now, the TC light is on and Steering wheel light. Im guessing its because the signal has been lost from steering wheel angle to the Traction Control. Hoping it goes off after a drive.
    The air bag light is also on now :s
    Thanks fgor your reply and sorry for my late reply!
    #3

Share This Page