1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No dash illumination or climate control

MooLard Oct 10, 2013

  1. MooLard

    MooLard Member

    229
    18
    18
    Evening, just wondering if anyone has suffered temperamental lack of dash illumination as well as climate control only working when set to the front windscreen? It's annoying when it's only sometimes and I'm not sure the best order to check things in.
    Many thanks in advance
     
  2. MooLard

    MooLard Member

    229
    18
    18
    Right, read fault codes on this and at the most the climate control has come up with the fault that it is not ready sometimes, but no codes specifically about the dash illumination not working.
    I find it tends to happen more when I've left the car unlocked for a time whilst washing it and then go to drive it, so it could be related to waking certain modules back up. Anyone else had this issue?
     
  3. SmoothAssault

    SmoothAssault Will design for mods

    822
    53
    28
    Sorry Moo, not something I've ever experienced. Hopefully someone else 'round here can help you get it sorted.
     
    Last edited: Nov 19, 2013
  4. MooLard

    MooLard Member

    229
    18
    18
    Afternoon!
    I had a bit of time last weekend to remove my dash pod and disconnect the connectors, then reconnect them. No corrosion but I did it on the off chance that was the issue. I'll get some stereo keys soon too to re-check all of the connections behind there because at some point it was all removed to fit a Parrot kit. For now it's been ok though.
     

Share This Page