1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no central locking

Discussion in 'A3/S3 Forum (8L Chassis)' started by leonolves, Aug 29, 2011.

  1. leonolves
    Offline

    leonolves New Member

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    hi guys new to the audi just bought my first 1 a cheap one but a nice 1 and found no central locking(REPLACED BATTERY) when i open the drivers door with the key i can hear the boot pump thingy whining for around 10-15secs then stops also the indicators start flashing after around 20 secs of opening (NO ALARM NOISE)and it will only stop when i put key in ignition and turn, is this related.
    any help muchly appreciated. ive gathered the pump could be knackerd was thinkin about the replacement internals.
    any advice on anything please
    #1
  2. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    you can buy the pump rebuild kits on ebay. Its a pain in the arse to get to the pump but once youve got the trim of its a fairly easy job to do!
    #2
  3. leonolves
    Offline

    leonolves New Member

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    thanks steve. il go and remove it later on and take apart to confirm broken parts alltough i located it other day and didnt notice any rattling/snapeed plastic noise. you can definatley here the motor working upon opening door, hopefully this is the problem, thanks again
    #3
  4. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    does your boot open at all?
    #4
  5. leonolves
    Offline

    leonolves New Member

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    yes the boot opens with the key
    #5
  6. j3wce s3 turbo
    Offline

    j3wce s3 turbo New Member

    Joined:
    Aug 30, 2011
    Messages:
    5
    Likes Received:
    0
    hi pal i had this problem last year and its the graphite impeller inside the pump will be shattered into little bits and wont be creating vacuum to operate locks, the motor in the pump will be fine which is the whining noise you can hear from the boot lol. I purchased just the impeller part and motor seperate from the whole pump housing as you can seperate it from the 4 rubber bungs thingys lol i got this from ebay for £40 and as my pump motor was fine i just swapped over the graphite impeller and bobs ur uncle my central locking was up and running. Now i also had my clifford alarm wired to the central locking unit so when my locking pump failed at the time lol when i was driving down the road my alarm would go off every single time, what a nightmare it was so annoying haha driving down the road as if iv nicked my own car lmao. hope ya get it sorted m8 as it can mess up your alarm and imobilliser. get intouch if ya need any help j3wce
    #6
  7. j3wce s3 turbo
    Offline

    j3wce s3 turbo New Member

    Joined:
    Aug 30, 2011
    Messages:
    5
    Likes Received:
    0
    Hi again iv just searched for the part and ther is the exact part you need to fix your central locking pump, it the complete vacuum box with graphite impeller replacement inside.

    check it out pal only £39 to fix
    AUDI A3/A4 central locking pump replacement | eBay
    #7
  8. leonolves
    Offline

    leonolves New Member

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    thanks for your time s3 turbo much aprecited i will order the parts. when i get the parts and swap them will the remote just work as simple as that ?
    #8
  9. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    yes it should do. the pump is used to lock and unlock with air so if the pumps not working it wont unlock the central locking on the keyfob
    #9
  10. leonolves
    Offline

    leonolves New Member

    Joined:
    Aug 29, 2011
    Messages:
    5
    Likes Received:
    0
    nice 1 guys im gonna go and remove it now so i can open it up and confirm broken parts. any tips on removal i had a quick look wen first got it the yellow and blue pipes look a bit tricky to remove/unplug.
    also when/if i get it out will it be ok to use the car without it while i wait for parts or will ineed to put it back in, thanks
    #10
  11. j3wce s3 turbo
    Offline

    j3wce s3 turbo New Member

    Joined:
    Aug 30, 2011
    Messages:
    5
    Likes Received:
    0
    yea pal the air pipes just prise off and it all tucked away near subwoofer and try not to rip the sound proof foam covering lol i ripped mine. its the 3 screws on top of the motor the impeller inside will be shattered you need to replace it and put the little square pieces in the slots of the impeller. when you open it pal its simple. and yes your central locking will be fixed as the locks are getting air lol
    #11
  12. Jiny_P
    Offline

    Jiny_P New Member

    Joined:
    Oct 3, 2004
    Messages:
    23
    Likes Received:
    1
    Hi Guys, Wondering if someone could me, i am trying to fit the repair kit. I have managed to take the pump out and almost apart but i can not seem to get the motor out of the casing?? can someone please let me know how the motor comes out also is there a guide anywhere on how to fit the kit?? Thanks
    #12
  13. stevie e
    Offline

    stevie e Member

    Joined:
    Aug 5, 2010
    Messages:
    30
    Likes Received:
    0
    This is an easy fix,with the repair kit from ebay
    #13

Share This Page