1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No brake pedal after caliper change

Discussion in 'A3/S3 Forum (8L Chassis)' started by dnLcal, Jan 15, 2010.

  1. dnLcal
    Offline

    dnLcal Member

    Joined:
    Dec 19, 2009
    Messages:
    52
    Likes Received:
    0
    [Jan 15, 2010]
    Did a bit of a fluid change yesterday, (coolant, engine oil, haldex oil, brake fluid.)

    After doing the first brake went to lock up the bleed nipple and the caliper bleed nipple threads had stripped so got a new caliper today and fitted it, bled the caliper and now when i pump with the engine turned off i can get some sort of feel but wont pump up solid (but then it never did before).

    When the engine is turned on the brake pedal is extremly soft and does not get harder at all. the brakes work though as the caliper will lock the disc.

    Did a VAGCOM check and there is an ABS fault that is (AWD system no comms) which needs to be sorted but i cant see it being the problem with the brakes.

    Cant find a leak anywhere. just gona have dinner and then bleed the whole system.

    I read about assisted bleeding using computer software?

    Any ideas?

    Callum
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Jan 15, 2010]
    have you tried the force bleeding method using the spare wheel as pressure?
    be careful not to flip the seals in the master cylinder too...
    #2
  4. dnLcal
    Offline

    dnLcal Member

    Joined:
    Dec 19, 2009
    Messages:
    52
    Likes Received:
    0
    [Jan 15, 2010]
    Bled the brakes and no change, car is undrivable. drive it up and down my street and it will stop the car and lock the wheels so you cant push the car. the braking force is right at the bottom of the bedal but you feel no resistance at all!

    Any ideas? im stumped at the moment.

    Callum
    #3
  5. rossbrownlee
    Offline

    rossbrownlee Ross_S4

    Joined:
    Aug 16, 2009
    Messages:
    719
    Likes Received:
    0
    [Jan 15, 2010]
    did you bleed your master cylinder? just a guess.
    also, did you do your clutch slave as well?

    I have read you need to bleed your ABS pump as well, you can do it with vagcom.
    #4
  6. dnLcal
    Offline

    dnLcal Member

    Joined:
    Dec 19, 2009
    Messages:
    52
    Likes Received:
    0
    [Jan 16, 2010]
    All sorted now, car is out on stage well and truly late!! ha!

    Had to bleed the whole system with the engine running due to the vacum on the servo. took it out for a test drive and the car feels great now. also fitted a forge 007p today.

    Happy with the car now.

    Feel like a bit of a scopo seeming as it was a small change to the process that made all the difference. brakes feel better than they did before too :)

    PS bled master cylinder (both bleed nipples) and then all four corners, not done the clutch, thats a job for next weekend as i'm busy from tomorrow morning until fri night!

    Cheers.
    Cal
    #5
  7. rossbrownlee
    Offline

    rossbrownlee Ross_S4

    Joined:
    Aug 16, 2009
    Messages:
    719
    Likes Received:
    0
    [Jan 16, 2010]
    Nice one! i'll be doing this soon so that's good info!
    #6

Share This Page