1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Newbie With S3 Turbo issues!!

Discussion in 'A3/S3 Forum (8L Chassis)' started by mo_s3, Sep 8, 2010.

  1. mo_s3
    Offline

    mo_s3 New Member

    Joined:
    Sep 7, 2010
    Messages:
    26
    Likes Received:
    0
    [Sep 8, 2010]
    Moe in my New (old) 210 S3

    Hi guys, just saying hello, bought my first german last week and loving the change. Came from a 2.2 VTI Honda Prelude to a 210 Audi S3. I do have 1 or 2 issues im hoping you guys can help me with.

    I just had the downpipe changed a few days ago as a whole emerged from me getting alittle to happy with my right foot. the noise sounded like a blown exhaust but after changing the downpipe it went away. The noise is now slowly returning in the lower rev range (2k).

    Also the turbo is making an odd whistling noise and sometimes stops pulling for a second around 4k. does seem to be a bit down on power and the turbo feels like its sturggling.

    Hope you guys can help me, cheers..


    [​IMG]
    #1
  2. Ads

    Ads

    [Oct 2, 2014]

  3. jdas03
    Offline

    jdas03 Member

    Joined:
    Jun 29, 2009
    Messages:
    597
    Likes Received:
    1
    [Sep 8, 2010]
    Wow like the car! Looks like it's been lowered as well? Very nice!
    Not sure on the exhaust sound, sure someone can give some advice.
    But turbo issues could be down to a number of problems.
    Firstly the MAF air sensor always causes issues, very common to go, perhaps worth getting some readings if you have vag com diagnostics.
    Boost leaks are another thing that at 4k could possibly cause you to loose power.
    Another very likely thing is the coil packs, I believe at 4k they need to be working hard to produce the power your requesting, if they are on their way out this can cause the hesitation.
    As for confirming the coil pack someone else maybe able to tell you how to confirm if it's these, and the boost leaks really are looking at the pipes in the engine bay to see what's split or soft.

    Hope that helps a little, sure someone with more knowledge will answer soon :)
    #2
  4. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Sep 8, 2010]
    Thats got the potential to be a cracked wastegate housing inside the turbo.

    Odd that it went away when the downpipe was changed though.
    #3
  5. mo_s3
    Offline

    mo_s3 New Member

    Joined:
    Sep 7, 2010
    Messages:
    26
    Likes Received:
    0
    [Sep 14, 2010]
    Hi, found out my manifold had come loose due to not being secured properly by a mechainic, and will need new gaskets.

    Hes goin to get a mouth full very soon and thought il post this for anyone who has a similar problem.
    #4

Share This Page