1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Newbie with problem

GeeS3 Aug 9, 2011

  1. GeeS3

    GeeS3 New Member

    3
    0
    1
    Hi there . I have a W reg Yellow S3 , a beautiful car , but recently she has thrown up a problem for me . Whilst running stedy (below 3000RPM) there is no problem . But if i go higher , into hard turbo boost , the engine oil light quickly comes on and when i park up burnt oil smoke starts flowing from behind the engine (bulkhead side) It's not short on boost so i dont think its the turbo going , though it does point towards something in that area . Help me please .
     
  2. talentwalsh

    talentwalsh Member

    139
    0
    16
    Sounds like the oil feed to your turbo might be shot especially when you oil pressure light comes on. I would get that looked at asap, oil light is never good to see as vital parts of your engine may be starved and damaged.
     
  3. GeeS3

    GeeS3 New Member

    3
    0
    1
    I've took it off the road now . Trying to have a look at it myself . Cheers
     
  4. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    Hmmm not good, i think you have 2 problems, i would take the sump of and inspect your pickup...
    Oil leak could be from the rocker cover gasket...
    You have done right to cease using it until you diagnose the issues..
     
  5. GeeS3

    GeeS3 New Member

    3
    0
    1
    Cheers dave i'll check it tomorrow . You think the pickup could be blocked slightly with **** ?
     
  6. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    Its worth looking, its not hard to do..
     

Share This Page