1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Newbie with a limp mode problem .....

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Slinequattro, Sep 19, 2011.

  1. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
    [Sep 19, 2011]
    Hi,
    am a newbie on here as i have just bought my first audi (2005 2.0tdi Sline Quattro), i bought it privately last week, but just the other day the engine management light came on, so today i got a diagnostic check at a independent garage, the codes it through up are as follows:-
    19558
    1957
    P2102
    17075

    i havent a clue what they mean so if anyone has any ideas or could point me in the right direction i'd be greatfully thankful especially as this problem is very annoying, i cannit drive anyway over 60mph without it going into limp mode..

    regards
    Andrew
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. nally
    Offline

    nally MPG the new BPH

    Joined:
    May 19, 2010
    Messages:
    2,098
    Likes Received:
    31
    [Sep 19, 2011]
    needs a propper scan one of our members should be able to help.
    #2
  4. tdi-man
    Offline

    tdi-man Well-Known Member

    Joined:
    Jul 27, 2009
    Messages:
    1,611
    Likes Received:
    48
    [Sep 19, 2011]
    [h=2]19558/P3102/012546 - Motor for Intake Manifold Flap (V157): No Signal[/h][h=4]Possible Symptoms[/h]
    • Hard Shudder when turning OFF the Engine
    [h=4]Possible Causes[/h]
    • Fuse(s) faulty
    • Wiring and/or Connector(s) from/to Intake Manifold Flap Motor (V157) faulty
    • Intake Manifold Flap Motor (V157) faulty
    [h=4]Possible Solutions[/h]
    • Check Fuse(s)
    • Check Wiring and/or Connector(s) from/to Intake Manifold Flap Motor (V157)
    • Check/Replace Intake Manifold Flap Motor (V157)
      • Perform Output Test








    #3
  5. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
    [Sep 20, 2011]
    Hi tdi-man
    Where is this flap motor located? And are they easy to replace/cost? And would this cure the other codes? Sorry for all the questions with it being my first Audi am not familiar with these engines..
    Regards
    Andrew
    #4
  6. tdi-man
    Offline

    tdi-man Well-Known Member

    Joined:
    Jul 27, 2009
    Messages:
    1,611
    Likes Received:
    48
    [Sep 20, 2011]
    hi
    you need to delete codes and test again in a week to see if they come back.

    inlet manifold flap is £200 ish new but check the fuse first as that might be blown not sure of the top of my head which number fuse it is.

    when u shut engine of do u get a shudder if so a new flap is a good idea . as when u switch engine of it should be nice and smooth.

    if you search you will find alot of questions ans answers to your fault
    #5
  7. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
    [Sep 20, 2011]
    *UPDATE*
    I checked the fuses earlier only to find one 10amp blown so i replaced it, left it for a hour then drove it about 5mile to pick the other half up from work, a couple of mile along the road i noticed the EML was out so i took it on the dual carriage way when i hit 70mph limp mode kicked back in again...??? When arriving home i was expecting the little judder it made when engine was turned off...but nothing... it was nice and smooth..

    seems abit strange...... has anybody got any ideas ? will there still be the faults registered without the eml illuminated?

    regards
    Andrew
    #6
  8. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
    [Sep 28, 2011]
    Hi again
    Just had car scanned again at a Audi specialists and they've came back with fault code PO234??
    Has anybody any idea what can cure this problem, preferably the cheapest way!?

    Regards
    Andrew
    #7
  9. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
  10. aaa3
    Offline

    aaa3 Member

    Joined:
    May 11, 2009
    Messages:
    43
    Likes Received:
    1
    [Sep 29, 2011]
    #9
  11. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
    [Oct 5, 2011]
    hi again.
    i've just received delivery of innotec cleaning kit today to clean the veins in the turbo but was wondering what would be the best way to complete this job, i've had a look but there doesn't seem to be much room, especially with the exhaust and prop shaft in the way?

    also i've just noticed there seems to be a blown exhaust sort of sound when i accelerate upto about 1500rpm then its quiet, its the same when its idling, it goes quiet(how it should sound) then sounding rough(old diesel van springs to mind) however the revs never hunt or fluctuate in anyway...

    any help would be greatly appreciated.
    #10
  12. tdi-man
    Offline

    tdi-man Well-Known Member

    Joined:
    Jul 27, 2009
    Messages:
    1,611
    Likes Received:
    48
    [Oct 6, 2011]
    ive been told this is only a temp fix at some point u will need a new turbo.


    #11
  13. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
    [Oct 6, 2011]
    i know unfortunality.. but was hoping it might cure it until at least after xmas. is there any easier ways of getting to it ?
    #12
  14. Brodster
    Offline

    Brodster Shark Performance In Scotland Regional Rep Site Sponsor VCDS Map User

    Joined:
    Mar 17, 2011
    Messages:
    3,444
    Likes Received:
    801
    [Oct 6, 2011]
    I had exactly the same problem with my 2.0 TDI. Used to go into limp home mode and switching it off used to reset everything. It got that bad that it was going into limp home mode all the time. Booked it into Audi Edinburgh and got the turbo replaced after they diagnosed it.....price was £1350 fitted but seeing as the car had just gone out of warranty and they classed me as a valued customer I ended up paying just under £300.....WINNER.

    Regards

    Brodster
    #13
  15. 55_UK
    Offline

    55_UK Y.N.W.A.

    Joined:
    May 9, 2011
    Messages:
    300
    Likes Received:
    10
    [Oct 6, 2011]
    whats the mileage on your car?
    #14
  16. Slinequattro
    Offline

    Slinequattro New Member

    Joined:
    Sep 19, 2011
    Messages:
    13
    Likes Received:
    0
    [Oct 11, 2011]
    its quite high at 136,000
    #15

Share This Page