1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New oil pump (A4 B5 - AEB)

Discussion in 'A4/S4 forum(B5 Chassis)' started by Lee Goodall, Feb 25, 2008.

  1. Lee Goodall
    Offline

    Lee Goodall ..got my head together!

    Joined:
    Oct 22, 2007
    Messages:
    2,231
    Likes Received:
    1
    [Feb 25, 2008]
    Anybody had a new oil pump fitted? If so how much did it cost?
    I know it's a big job (lifting engine etc.) but it's got to be done :(
    #1
  2. Ads

    Ads

    [Sep 21, 2014]

  3. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,604
    Likes Received:
    276
    [Feb 25, 2008]
    AUDITURBO just did his, i am sure he said the pump was under £60, but hasny answered how easy / hard the work was etc. I am gonna do mine this week so can let you know then, maybe a write up etc
    #2
  4. Lee Goodall
    Offline

    Lee Goodall ..got my head together!

    Joined:
    Oct 22, 2007
    Messages:
    2,231
    Likes Received:
    1
    [Feb 25, 2008]
    That's be good. Cheers.
    #3
  5. g60leigh
    Offline

    g60leigh Well-Known Member

    Joined:
    Jun 16, 2007
    Messages:
    1,421
    Likes Received:
    128
    [Feb 25, 2008]
    had mine done due to low oil pressure but it ended up being a small pressure valve that goes into oil filter housing!
    may be wirth checking that 1st if your having pressure probs!
    #4
  6. AUDI TURBO
    Offline

    AUDI TURBO Member

    Joined:
    Nov 28, 2007
    Messages:
    577
    Likes Received:
    0
    [Feb 26, 2008]
    yes sorry people i did have mine done pump cost about £60.00. it was abit of a ball acher need to take front of car off. need hoist equipment to lift engine up even then it still didnt get high enough!! abd lots of tight bolts and awquard places. myd ad started it while i at work so i only helped fitting pump and putting back together. we were lucky too we managed to attach subframe about same so no pulling while driving!!!
    #5

Share This Page