1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New here and need help with codes.

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by 98Quattro, Jul 19, 2008.

  1. 98Quattro
    Offline

    98Quattro New Member

    Joined:
    Jul 19, 2008
    Messages:
    1
    Likes Received:
    0
    [Jul 19, 2008]
    Hi there. I'm a newb on this site and wanted to say hello.
    I own a 98 A6 Quattro 2.8L.

    I just replaced my pre-cat O2 sensors about a week ago and the check engine light came on. With my buddy's VAG-COM I received these codes:

    Address 01: Engine Labels: 078-907-551-AHA.lbl
    Part No: 4D0 907 551 AH
    Component: 2.8L V6/5V MOTR AT D01
    Coding: 06252
    Shop #: WSC 23261
    5 Faults Found:
    16795 - Secondary Air Injection System: Incorrect Flow Detected
    P0411 - 35-10 - - - Intermittent
    16535 - Oxygen (Lambda) Sensor B2 S1: Signal too Low
    P0151 - 35-00 - -
    16515 - Oxygen (Lambda) Sensor B1 S1: Signal too Low
    P0131 - 35-00 - -
    17604 - Oxygen (Lambda) Sensor Heater Circuit: B1 S1: Electrical Malfunction
    P1196 - 35-00 - -
    17605 - Oxygen (Lambda) Sensor Heater Circuit: B2 S1: Electrical Malfunction
    P1197 - 35-00 - -
    Readiness: 0000 0000

    And

    Address 08: Auto HVAC Labels: 4B0-820-043-MY1.lbl
    Part No: 4B0 820 043 G
    Component: A6-Klimavollautomat D61
    Coding: 00160
    Shop #: WSC 42006
    1 Fault Found:
    01273 - Fresh Air Blower (V2)
    17-10 - Control Difference - Intermittent

    We reset the codes and last night the CEL came back on. I know my secondary air Injection pump is bad since last year but the CEL has always gone off. This one stays on.
    What could it be? What is the fresh air blower?

    Thanks in advance.
    Al
    #1
  2. Ads

    Ads

    [Sep 21, 2014]

  3. Flying Spanner
    Offline

    Flying Spanner Member

    Joined:
    Oct 11, 2008
    Messages:
    30
    Likes Received:
    0
    [Oct 12, 2008]
    Hi, you need to check the circuit for voltage supply to the O2 heater elements. As it shows bank 1 AND bank 2 sensor 1 (pre cat) start with the fuse and work down the wiring diag to earth.
    Your secondary pump being faulty wont help the low flow. If its bad, it can blow the Ebox fuse. Also check the rubber vac hoses down the back of the heads going to the combi valves, they always perish on the early V6 engines and cause a fault log but it would say bank 1 or 2 (cyl 1-3 or 4-6).
    The O2 sensors pick up when the secondary air is working so as they are showing signal too low you would be best trying to sort this issue first.
    Why did you replace the sensors? was it due to these fault codes or did these codes appear after replacing the sensors?
    Did you use genuine parts/second hand or pattern parts when they were replaced?
    #2

Share This Page