1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New fault but no DTC's this time

Discussion in 'A4/S4 forum(B5 Chassis)' started by S4_dan, Sep 24, 2011.

  1. S4_dan
    Offline

    S4_dan Fire up the Quattro!

    Joined:
    Jan 5, 2006
    Messages:
    1,750
    Likes Received:
    79
    [Sep 24, 2011]
    Car has decided to play up yet again, only this time, no DTC's present.

    usually happens in 3rd or 5th gear but has happened in others....

    Driving along, revs around 1500rpm and car stutters and hesitates. I'm not accelerating, just holding the speed and can feel the car. Plant my foot down, juddering worsens for about 30secs before car returns to normal and starts to accelerate.

    Or, driving along, drop to third to overtake, plant foot, 30secs of juddering, no power, no aceleration.....then kaboom....off like a rocket!

    Plugs and leads appear to be in good condition.

    Any pointers please?

    Cheers,

    Dan
    #1
  2. Ads

    Ads

    [Oct 21, 2014]

  3. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,696
    Likes Received:
    331
    [Sep 24, 2011]
    MAF perhaps?

    Try unplugging it and see if the problem goes away?
    #2
  4. S4_dan
    Offline

    S4_dan Fire up the Quattro!

    Joined:
    Jan 5, 2006
    Messages:
    1,750
    Likes Received:
    79
    [Sep 24, 2011]
    Ok, will try that Aragorn, thanks.
    #3
  5. S4_dan
    Offline

    S4_dan Fire up the Quattro!

    Joined:
    Jan 5, 2006
    Messages:
    1,750
    Likes Received:
    79
    [Sep 24, 2011]
    Tried it and car ran 80% better. Plugged back in and it went **** again after a few miles so unplugged for rest of journey home. Got home and noticed smoke coming from exhaust and smelt very very rich.

    So a new MAF i thinks!

    They're not cheap....anyone know if i can change just the sensor unit (like i could on my 2.5 V6 Tdi A6) Or is it the full housing unit only on these A4's?
    #4
  6. Oranoco
    Offline

    Oranoco Well-Known Member

    Joined:
    Jul 27, 2007
    Messages:
    3,209
    Likes Received:
    204
    [Sep 24, 2011]
    From my experience with MAFS get a genuine Bosch one not a Pierburg or pattern one as they are utter ****!!!
    #5
  7. S4_dan
    Offline

    S4_dan Fire up the Quattro!

    Joined:
    Jan 5, 2006
    Messages:
    1,750
    Likes Received:
    79
    [Sep 24, 2011]
    Yeah, I have in the past with previous Audis. Even had a genuine Bosch part fail within 3 months! Went straight back to VW stealer and got it replaced.

    Took the car out again tonight, still with maf unplugged, and it was hesitating like it did before with maf plugged in!?!?!

    So could be something else as well as the maf having failed? Mpg is averaging around 28 at the moment. Was upto 34 two weeks ago when i fitted two new lambdas!!
    #6

Share This Page