1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need help fault code

audi-90qua Oct 25, 2007

  1. audi-90qua

    audi-90qua New Member

    12
    0
    1
    i have audi 90 1993 quattaro there is a check engine light showing so i like to know how should i check the codes and how it works . is it easy to check by myself? i had 300zx i know how to check my other car . if any one knows how to do by diy plz give me the details with number codes.
    Thanks
     
  2. enda1

    enda1 Member

    436
    0
    16
    for that age of car you will also need the 2x2 adaptor cable to connect the car to the vagcom software
     
  3. shineydave

    shineydave Member

    920
    5
    18
    you can do it by shorting the terminals on the diagnostic sockets together but unfortunately it's a while since i had a type 88 car so i can't remember the sequence. depending on the ECU version the codes may be displayed by flashing the CEL on and off in sequence in the dashpod or it's possible you may have to connect an LED to the plugs to see the sequence of flashes.
     
  4. shineydave

    shineydave Member

    920
    5
    18
  5. scotty33

    scotty33 Member

    155
    0
    16
    You have a functioning check engine light, so it should be possible to flash codes out on that. The diagnostic connectors are probably in the fusebox on the V6, rather than under the dash (like the 20v).
     
  6. audi-90qua

    audi-90qua New Member

    12
    0
    1
    how should i do flash code checking by myself?i have 300zx 91 i know how to check that but dont know about audi 90.plz can someone tell me in detail how should i check flashing in speedometer?
     
  7. shineydave

    shineydave Member

    920
    5
    18
    i thought the link i posted explained the process in sufficient detail, what are you specifically having problems with?
     
  8. audi-90qua

    audi-90qua New Member

    12
    0
    1
    Thanks shineydave i will do the way you said but need little help the door vacume is not working and rear doors and trunk are locked i tryed to open from inside and out side still its not working.i like to know that vacum lock have pipes and does it have electronic wiring to?how should i open it
     
  9. scotty33

    scotty33 Member

    155
    0
    16
    The front doors, rear doors, trunk and filler flap all have actuators, if you can hear the pump running for much more than 5 seconds there is probably a leak somewhere.
    I have had a problem with the 'piston rod' seal blowing off the filler flap actuator. this suggests to me that the vacuum pump provides vacuum for one mode, and reverses to provide pressure for the other mode, (modes being lock/open functions.) The actuators only have an air/vacuum supply to one side, which kind of bears this out?
     
  10. shineydave

    shineydave Member

    920
    5
    18
    you should be able to open the trunk using the key, at least you can on all the other Audis i've owned, the back doors should open from inside unless someone has operated the child locks in which case you need to get the central locking working
     
  11. audi-90qua

    audi-90qua New Member

    12
    0
    1
    hi
    i tryed open the trun with the key its not working and tryed to open the rear door lock still not opening the only front 2 door opening with the key and when i turn the key to open the lock it doesnt make any noice.
     
  12. shineydave

    shineydave Member

    920
    5
    18
    have you tried all 3 positions for the trunk lock, you should have "locked" "unlocked" and "permanently locked" which leaves the trunk locked when the rest of the car is unlocked. if you get the key into the "unlocked" position it should open by pressing the trunk lid button
     
  13. audi-90qua

    audi-90qua New Member

    12
    0
    1
    hello
    today i tryed to open the trunk with the key it was jamed and still by force i turn the key and open the trunk and i checked the motor of vacum in the trunk it was all wet and not working smell like the unit is burned so u think its reapir able?or need to get used one?
     

Share This Page