1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My minor modding thread

Discussion in 'A3/S3 Forum (8L Chassis)' started by <tuffty/>, Jul 29, 2009.

  1. hilly
    Offline

    hilly Member

    Joined:
    Oct 11, 2009
    Messages:
    236
    Likes Received:
    16
    [Jan 30, 2011]
    one word comes to mind.......
    awesome!
    i want ago lol
  2. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 6, 2011]
    Righty... made a start this afternoon, I have all next week off and the plan is to port the wastegate to stop the boost creep, fix the small coolant leaks from the turbo hard pipes, replace the VVT/cam chain tensioner and if I have the time replace the front strut tops with harder/uprated LCR ones, new bearings and replace the front wheel bearings as there is a little hum coming from one of them... I also need to replace the cheap pattern part inboard drive shaft gaiter by the down pipe as its turning to dust... knew I should have got an OEM one... they are far more resilient... might have to see if I can add some extra heat shielding in to help protect the gaiter more...

    Anyhoo... usual story, remove half the engine bay to get to the head...
    [​IMG]

    ...Bill and I lifted the head off... awkward bit of kit with the turbo and all its lines on :(
    [​IMG]

    ...seeing as I had cleaned up the pistons when I fitted the large port on and have only done nearly 5k miles since the pistons are a little coked... the engine was running rich on idle and making some bizarre lambda correction swings... pretty sure this is a symptom of the dodgy cam chain tensioner as it was fine before... other than the bit of carbon build up everything else was fine... no det marks (not that I expected any) and bores all clean...
    [​IMG]

    ...removed the turbo which is also still looking in good shape... comp housing is totally free of oil (thanks to not having the PCV venting oil back into the intake, and having a ball bearing turbo of course)... hotside will come off tomorrow and then the wastegate can be ported... then weld a bead round the edges of the water pipes as they leak a little when cold and fix the small weap from the other pipe...
    [​IMG]

    Other than a little carbon build up which I will clean up the head is in great shape so all looking good...
    [​IMG]

    ...all in all a good afternoons tinkering... although there was a bit of a fail on my behalf and just as well I removed the inlet mani... I took the effort to blend the transition phenolic gasket and the large port/small port gasket but then in my haste to get the car back together and give Bill his ramp back (due to the delays of getting the turbo fixed etc...) I managed to fit the small port gasket on the largeport side and the largeport gasket on the small port side... which obviously doesn't help flow...DOH!!!!
    [​IMG]

    Ah well... all part of the experience :thumbsup:

    Back on it tomorrow....

    <tuffty/>
    Last edited: Feb 6, 2011
  3. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,597
    Likes Received:
    274
    [Feb 6, 2011]
    DOH!!!

    On the gaskets mate, all part of the learning curve.

    At least you know where your car is....LOL
  4. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Feb 6, 2011]
    :slap:

    Bummer. Oh well, at least it's found now....

    Good work getting the head off dude - what's it looking like?
  5. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 7, 2011]
    ...like the pics and write up in the earlier post... lol

    <tuffty/>
  6. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Feb 7, 2011]
    I missed that one.... Joys of ASN on my phone....
  7. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 7, 2011]
    Busy day.... started by removing the hotside from the turbo so Bill could give it a tickle with the Dremel...
    [​IMG]

    Bill attacked it with the Dremel and the wastegate went from this...
    [​IMG]

    ...to this...
    [​IMG]

    [​IMG]

    ...just as well as going external gate was gonna be a whole lot more work :(
    [​IMG]

    [​IMG]

    Put the turbo back together and reset the actuator position and preload... opens at 12/13psi as expected...
    [​IMG]

    Then I started on replacing the can chain tensioner/VVT unit... there are plenty of guides on the interweb for doing this and it can be done without removing the head... all you essentially need to do is undo the inlet cam...
    [​IMG]

    ...tensioner removed being careful not to alter the cam timing...
    [​IMG]

    ...really impressed with the quality of the 'ebay' unit vs the OEM one...
    [​IMG]

    ...don't forget to replace the gasket and seal (available as a kit from Audi)..
    [​IMG]

    ...unit fitted...
    [​IMG]

    ...cam caps refitted and ready to go...
    [​IMG]

    Back at the unit tonight and hopefully should have the turbo back on the head but I have a bit of cleaning to do first so head will more than likely go back on tomorrow...

    ....finally, watch this space...
    [​IMG]

    <tuffty/>
  8. S3KO4
    Offline

    S3KO4 Member

    Joined:
    Aug 15, 2009
    Messages:
    850
    Likes Received:
    2
    [Feb 7, 2011]
    Nice space for an LPG tank! :)
  9. Andrew@A.L.D
    Offline

    Andrew@A.L.D Cylinder Head Master

    Joined:
    Jun 19, 2009
    Messages:
    3,515
    Likes Received:
    361
    [Feb 7, 2011]
    I never thought about putting my pump in the wheel well

    Shame you can't hide the water tank in there unless you get a custom made one?
  10. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 7, 2011]
    Fabrication is what we do ;P

    <tuffty/>
  11. finesse
    Offline

    finesse Active Member VCDS Map User

    Joined:
    Aug 15, 2006
    Messages:
    2,811
    Likes Received:
    10
    [Feb 7, 2011]
    what pump is that
  12. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,331
    Likes Received:
    695
    [Feb 7, 2011]
    Devils own, stage 2 pump
  13. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Feb 7, 2011]
    Wish my head looked that clean..... lol.
  14. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 7, 2011]
    Its only been on the car for just shy of 5k miles mate from the original rebuild so I would worry if it wasn't lol....

    Anyhoo... on that same subject I have been cleaning the head and the pistons to remove the coked up **** from it running rich for 5k... took the tensioner damper off to reset it ready for when the belt goes back on and noticed the piston wasn't up against the circlip so looked on one sat on the shelf and sure enough the piston was lower on mine... thats a tad worrying to say the least... this will be replaced tomorrow with a new one... it was a part from GSF but was from the OEM and just had the 4 rings machined off... the damper has done no more than 20k in the car as I fitted this and a new belt etc at around 85/90k... one reset too many maybe...

    These are not normally part of a cambelt change from a dealer I should add so you need to insist they do it as these DO and WILL fail... I have seen this happen..

    Off the GSF in the morning then and will be putting the head back on when I get back to the unit...

    After that I will start plumbing in the WMI :eyebrows:

    ...although I will be using a temporary tank until I sort out fabricating an alloy one for the spare wheel well... while I am at that I may have a look at fabricating the oil catch tank to fit in the space by the air filter...

    <tuffty/>
  15. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Feb 8, 2011]
    My tensioner damper went the same after I had reset it a few times. I would 100% replace that part if anyones planning a major service soon as not many people seem to change them but they do fail or go weak.

    Your engine bay and head is very clean lol no oil anywhere.
  16. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 8, 2011]
    Long bloody day!! not the best either... water pipes are now all sorted so shouldn't weep any more... heads back on and I have started putting everything back together... first major fail of the day was not getting the crappy engine mount bracket thing in the right place before refitting the cam belt (which went on first time as well!!!) so had to take it all apart and remove the damper to move the damn thing into position etc blah.... all done now...

    Got the engine mount back on and went underneath the sort the water pipe and fix the DP only to discover I had left the original heatshield that fixes to the transfer box top protect the CV gaiters in place as I was test fitting it earlier to see if I could use it... I removed it on the original build and never got around to refitting... only the DP hit it as did the oil drain! it was a knob to get to the nuts to remove it and it still won't come off as its caught between the inner CV and oil drain from the turbo.. DOH!!! like Welly I was having a bad day!!

    Drive shaft off tomorrow then and lessons learned... should get the old girl started tomorrow though...

    One thing I have realised working on the car solidly for the past three days is that sitting in front of a computer all day is not actual exercise... I ache all over!!!

    <tuffty/>
  17. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Feb 8, 2011]
    Still progress tuffty, a bit disheartening when things fook up, but you will get there....
  18. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Feb 8, 2011]
    These things are sent to try us mate, if it wasn't for the bad days, you wouldn't appreciate the good.

    **** happens, there are ways around it, it's all good.

    Think of the finished product.... I've been doing that for months.
  19. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 9, 2011]
    Much better day today... started off with a quick win and changed the rear ARB drop links as one had gone and was knocking a good un... then undid the inboard CV joint and ball joint to swing the driveshaft out of the way so (with a bit of gentle persuasion) I could remove the heatshield... yay!

    Then it was just a case of putting the bits I had removed back on, refill fluids and start her up... pleased to report that she fired up fine and no fault codes etc...

    Called it a day at that point so will check her over tomorrow for potential leaks etc and make sure all is good before putting the rest of the bits on and driving her out the workshop for a test drive.... was hoping to squeeze a dyno run or two in but I need to leave early so may not get a chance... the runs are really only to make sure the boost creep issue is sorted and then we can work out where to go with the mapping once we know she is running as she should be...

    <tuffty/>
  20. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 9, 2011]
    ...while I was putting the engine bay back together I though I would test fit a potential future upgrade... ;P

    [​IMG]

    [​IMG]

    <tuffty/>
  21. superkarl
    Online

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,614
    Likes Received:
    1,102
    [Feb 9, 2011]
    2 Sets of injectors? Cool , what manifold is it? Off bills car I'm guessing?
  22. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 9, 2011]
    SEM mani from Bills Ibiza race car... he runs 2 sets of injectors but is on standalone management... std S3 ECU can't do that...

    Was trying it out to see what fitting implications might be... still 700/800 quid to buy and maybe I'll get some more power but I am not running a tubular mani and have a T25 flanged turbo so I won't see full flow potential... lot of money for not much gain tbh...

    If one comes up cheap then maybe but rather save my cash now for sorting the paint work out on my car and eventually going 1.9/2.0ltr...

    <tuffty/>
  23. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Feb 9, 2011]
    Does that manifold include the towbar for the v power fuel tanker.....
    AVLO likes this.
  24. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,331
    Likes Received:
    695
    [Feb 10, 2011]
    my ibiza needs a small trailor to follow with fuel. endurance racer it aint ever going to be!
  25. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 10, 2011]
    Car is now back together so I spent a couple of hours on the dyno to see whats what... boost creep issue is no longer an issue... Yay!

    Held around 10psi to the redline on actuator pressure but fuelling is still going rich after 7k... not due to EGT's measured at the probe as they were just over 800 degrees and protection doesn't kick in until 925 degrees...

    Did some runs then using the MBC/N75 in parallel on the soft spring and wound right in... started at around 17psi which is much better than before as the boost was going all over the place... increasing the boost via the MBC still only seemed to induce a bigger spike followed by a wobbly lower hold pressure...

    Changed the MBC spring to the stiffer one and bingo... 22psi...

    Then tested the pressure drop from the turbo to the manifold.... 32psi at the turbo initially!!! a difference of 8psi tailing off to around 5 or 6psi.... Bit too much methinks and it would appear I have maxed my FMIC... need to get on and visit AH Fabs...

    Airflow wise I maxed the MAF from 6k on at 292.58 g/s.... Will try and sort some graphs out later once I have them sorted..

    Minor fail of the day seems to be my rattle that I thought was the cam chain tensioner... still rattling but for a different reason I think... oil pressure... there is pressure there (but have knocked the dyno runs on the head for the time being) but when the oil gets hot I get a fault appear (16395/P0011/000017 - Bank 1: Camshaft A (Intake): Retard Setpoint not Reached (Over-Advanced)) so thinking the pressure on low revs isn't high enough... I did test drive the car after she had cooled down a bit and the code hasn't come back yet...

    Will look into that one a bit further before making a final diagnosis but I am just going to replace the oil pump anyway and then at least I know its done...

    That is about it for now I think tuning wise... not going to push the engine until the pump is changed and I need to sort a larger FMIC out to get less pressure drop...

    Boo...

    <tuffty/>
  26. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,570
    Likes Received:
    313
    [Feb 10, 2011]
    I doubt you maxed the MAF, more like maxed out VCDS.

    The MAF should read to around 340g/sec, whereas VCDS stops reporting just under 300.

    Oilpressure isnt good, but i maintain that ALL tuned 1.8T's should have a pressure guage. The built in warning is absolutely hopeless. My old 1.8T A4 had only 8psi at hot idle, and would manage about 1bar per 1000rpm when revved. This is miles below spec, and 8psi at idle was enough to set the lifters clattering, yet the pressure light never came on. It wasnt sludge either, just a worn oil pump, the pickup was clear. The replacement engine with a new pump would see over 15psi at idle, and was showing 5bar by just over 2k.

    What oil are you using? If its 5w30 get shot of it, as it thins down too much when hot further reducing pressure. With your engine i'd probably be looking at a 50weight synthetic, although a 40weight will probably be fine if most of your driving is "normal" rather than full bore.
  27. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,331
    Likes Received:
    695
    [Feb 10, 2011]

    Nope it does not read that high on tufftys...
    4.98v measured saturated output is 292.58g/s maxed sensor output on 80mm maf sensor

    it will not do 340g/s
    where did you get that info from? got a link?
    Last edited: Feb 10, 2011
  28. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Feb 10, 2011]
    Bigger maf housing, same sensor and map to suit?
  29. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,331
    Likes Received:
    695
    [Feb 10, 2011]
    RS4 tube an option
  30. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,570
    Likes Received:
    313
    [Feb 10, 2011]
    Mass air flow - S4wiki

    That suggests the S4 sensor in the same 73mm tube will read to 364g/sec.

    You yourself in another thread posted that the stock S3 map has ~340 programmed in, and that occurs at only 4.88 volts (iirc).

    Its a known issue that Vagcom cant read out to these sensors maximum values. The S4 Wiki shows the limits vagcom will read on various S4 ECU variants, so theres no reason to think the S3 will be any different. A DMM on the sensor wont neccesarily be accurate, unless its tied to the same signal ground the ECU is using, and most DMM's wont react very well to a rapidly changing signal such as that the MAF outputs.
  31. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Feb 10, 2011]
    Paul, I had that code on my car for ages and done loads to it to get nd get rid of the code and it turned out to be the actual VVT unit. I didnt think it would have been that as it was a brand new one from ebay so ruled that out. To be far the VVT I got from ebay worked perfectly fine till my cambelt snapped and that messed it up somehow.

    I changed the oil pick up twice, change the oil pump and had my oil pressure checked and all was ok and even re done my timing and change the cam and crank sensor but still got the code once the oil got hot. Put my old OEM VVT back in and the code never come back "touch wood". You can check your oil pressure on vag com but just say if oil pressure is ok or below minimum.

    If the code reappears put your old VVT unit back in before you chane any other parts.
    Last edited: Feb 10, 2011
  32. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,331
    Likes Received:
    695
    [Feb 10, 2011]
    No I did'nt say that.. I've measured the fecking thing myself & seen the code which scales it.. and its upped to its max..
    and the voltage measurment made was sound, thank you ;)

    http://www.badger-5.com/bin/published-bosch-sensor-data.pdf
    page 56 onwards has some good info on hot film maf's and their voltage outputs, and linerity (or lack thereof up top)

    RS4 sensor tube I said also (I used to run one on my ibiza & have it sat on my self)
    Last edited: Feb 10, 2011
  33. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 10, 2011]
    Thanks mate... the code has come back again (just checked) but haven't been giving her the beans on the drive back from the unit... still gonna change the oil pump for peace of mind and take it from there... if push comes to shove I'll just have to bite the bullet and buy an OEM one when I have some spare cash but got to tax 2 cars this month so not gonna happen just yet...

    <tuffty/>
  34. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Feb 10, 2011]
    Ye, good call changing the pump for peace of mind, and not that expensive either £55 from GSF I paid. If your still get the code put the old VVT in and drive it for a couple of days and see if that gets rid of the code, if it does get a new one then.

    I wasnt getting and fault codes on my original VVT but it was noise on start up and warm idle so got the ebay one. If you didnt have any codes with the old VVT its worth putting that in first to check that gets rid of the code then get your new one. I nearly sold my car from that code, was costing me loads of money and stress trying to get rid of it and in the end to get rid of the code cost me nothing just putting my old VVT in, wish I put the old one in first lol.
  35. S3 Paul
    Offline

    S3 Paul Well-Known Member Regional Rep

    Joined:
    Oct 27, 2006
    Messages:
    2,785
    Likes Received:
    75
    [Feb 10, 2011]
    How do you check for preasure drop over the FMIC?
    I would like to do this with mine
  36. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 10, 2011]
    Used the dyno loggers boost input, first tee'd from FPR for mani pressure then tee'd off the N75 outlet on the charge pipe... as close to the turbo as you can get really on an S3... you could just connect your boost gauge to it...

    Did the test during back to back dyno runs for consistency..

    <tuffty/>
  37. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,909
    Likes Received:
    1,333
    [Feb 10, 2011]
    Dyno'd with actuator pressure only... 10psi...
    [​IMG]

    ..and the boost pressure difference tests...
    [​IMG]

    <tuffty/>
  38. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Feb 10, 2011]
    Holy jesus she's making some pressure at the turbo then!! lol. 32 PSI? Deffo time to investigate what difference a bigger cooler will make.

    Bummer about the oil pressure, but not the end of the world dude. I thought I could still hear that sound from the top end last night on first run. I am beginning to suspect that I may need a new oil pump soon...

    However, on the plus side, that boost creep has gone toodles.... Nice graphs on the boost. I'm pleased for you with that result - good work! :thumbsup:

    Porting FTW!! :eyebrows:
  39. s3 man
    Offline

    s3 man Member

    Joined:
    Feb 15, 2010
    Messages:
    105
    Likes Received:
    0
    [Feb 10, 2011]
    Tuffty where did you get your intake pipe that goes to the airbox from?also where have you fitted the other air feed pipe to?
  40. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,570
    Likes Received:
    313
    [Feb 10, 2011]
    So the S3 MAF uses a different sensor to the S4 one then?

Share This Page