1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mudflaps don't fit - Part Nos correct?

Discussion in 'Audi S4/A4/A4 Cab (B8 Chassis)' started by shanevo6, Aug 13, 2009.

  1. shanevo6
    Offline

    shanevo6 New Member

    Joined:
    Aug 13, 2009
    Messages:
    3
    Likes Received:
    0
    Hi, I have just purchased a set for my 2007 Cab' 2.0TDi from Milton Keynes Audi. The pre drilled holes in the rear ones don't line up at all with the ones in the under arch & only one on the front appears to be somewhere near. Part Nos are Front 8E0 075 111 A - Rear 8EC 075 101. I called Gloucester Audi (where I live) & he said they should be, Front 8H0 075 111 A - Rear 8H0 075 101? I have just double check with MK Audi & he assures me they are the correct ones?

    Any ideas guys? :think:

    Rgds
    Shane
    #1
  2. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,261
    Likes Received:
    1,223
    Welcome to the site Shane.

    1st thing to note is post in the right section mate as yours is a B7 & this is the B8 area.

    The 8E0 are correct for the 07-09 A4 cab & other A4 range cars including the previous B6 chassis.

    The 8H0 part numbers are slightly wrong, but they are for the 03-06 A4 range including cab, got a pic of yours to confirm shape.

    8H0 075 111 & 101
    Last edited: Aug 13, 2009
    #2
  3. shanevo6
    Offline

    shanevo6 New Member

    Joined:
    Aug 13, 2009
    Messages:
    3
    Likes Received:
    0
    Hi, sorry about using wrong forum (just assumed mine was B8 as it says from Jan 2007 onwards). I'm still confused as there is no way these will fit & I would expect factory supplied parts to line up perfectly. I have since phoned Cardiff Audi who first quoted 8EO then said oh no that's for Saloon & Avant, & so I require 8H0 which is for 2002 Cab onwards. Did the shape change at all from 2002? Don't know what to do now as worried 8H0 won't fit either?

    Thanks for reply

    Shane
    #3
  4. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,261
    Likes Received:
    1,223
    Well B6 was from 01/02 IIRC as mine was an 03 S4 Avant, I tell yer my parts guys are spot on but you boys have nothing but problems, then again I use etka daily & I have to agree it can be confusing for people that arent that savvy with the system or are new to it as its not perfect for sure, I've found many issues in parts not showing even if car exists, lol.

    Did you resolve anyway?
    #4

Share This Page