1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mpg gone really poor help please

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by L3WJX, Oct 6, 2012.

  1. L3WJX
    Offline

    L3WJX Member VCDS Map User

    Joined:
    May 14, 2010
    Messages:
    223
    Likes Received:
    0
    [Oct 6, 2012]
    Hello another problem starting from today,I have just had a 6 hour drive with a poor mpg of 25/30 on motorway cost me a lot more than normal,I was seeing 45/55 on way up there 3 days before,what could be causing this I have had it on vagcom and no luck .
    #1
  2. Ads

    Ads

    [Sep 24, 2014]

  3. fishyfish
    Offline

    fishyfish Member

    Joined:
    Apr 18, 2012
    Messages:
    126
    Likes Received:
    36
    [Oct 6, 2012]
    At the risk of sounding daft, have you heard any new noises? Maybe the handbrake is not fully disengaging (i.e. needs adjusting), or you have a stuck caliper, which would cause a lot of drag... but you'd probably hear some sort of squealing or rumble if that was the case.
    #2
  4. L3WJX
    Offline

    L3WJX Member VCDS Map User

    Joined:
    May 14, 2010
    Messages:
    223
    Likes Received:
    0
    [Oct 6, 2012]
    Yh car pulls well and car brakes all seem ok,think it tends to be worse in 6th gear just drops a lot,scanned on vagcom no joy also reset all engine codes by adaption and 00 reset,anything else I could check temp gauge sits at 90c but sometimes drops a bit then comes up again,looked last night at coolant and tool cap of and started pissing out looked like it wasn't circulating but I'm no mechanic,any I e have any ideas let me no x
    #3
  5. L3WJX
    Offline

    L3WJX Member VCDS Map User

    Joined:
    May 14, 2010
    Messages:
    223
    Likes Received:
    0
    [Oct 7, 2012]
    Just been told could be the head gasket,due to juddering through gears some times more like a flat spot at low revs,smoking exhaust and no temp out of heaters is there a way I can check this,also has a judder on stand still bit rocky,what does this sound like also waterpump don't feel like its recirculating properly but the car does not over heat,
    #4
  6. sidibear
    Offline

    sidibear Looking for Zombies !! Staff Member Moderator

    Joined:
    Nov 5, 2008
    Messages:
    2,058
    Likes Received:
    442
    [Oct 8, 2012]
    Most garages can check the coolant for the presence of exhaust gas with a kinda sniffer thingy to see if the head gasket has gone.

    Didn't fill up at a Sainsbury's did you?
    I did the other week and my mpg went out the window, now filled up with Shell good stuff and its back to normal, maybe some crappy fuel?
    #5
  7. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,187
    Likes Received:
    40
    [Oct 8, 2012]
    Linked with what sidibear said, when did you last have your fuel filter changed?
    #6
  8. L3WJX
    Offline

    L3WJX Member VCDS Map User

    Joined:
    May 14, 2010
    Messages:
    223
    Likes Received:
    0
    [Oct 8, 2012]
    Hiya the car had full service last month and no the fuel was was good it happen after me trying to get the heaters to work and me revving the car quite abit,had the car tested for head gasket and that looks ok,I get little flat spots through gears at low rpm,poor mpg,an at idle it feels like it judders,also sometimes grey smoke not all the time though,could this be air mass or egr valve ?? But no engine management light has come on,how would I check air mass ?? I have vagcom but no codes if anybody else could help be good.
    #7

Share This Page