1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MOT Fail

Discussion in 'A3/S3 Forum (8L Chassis)' started by 666markyboy, Dec 15, 2009.

  1. 666markyboy
    Offline

    666markyboy Active Member

    Joined:
    Mar 17, 2008
    Messages:
    1,123
    Likes Received:
    32
    :keule:

    A bit of help needed guys.... i'm currently trawling the threads but if anyone help upfront that would be great.... car is A3 Quattro and both rear coil springs have snapped,,,, i've got a couple of new springs today... same as a TT apparently £35 +VAT each from GSF.... whats the procedure for changing them out ??? iv'e some spring clamps but it's very cramped in there and i'm strugling to get them to really clamp down on the springs.... will undooing the shocker allow the rear arm to come down further??? my Haynes manual dosn't cover Quattro

    Second problem... not an MOT fail but noticed it today coming back from picking the springs up... my temp guage has started dropping down to nothing and then coming back up again every now and then.... i've had VAG COM on it and whilst the engine was running the guage showed no temp but VAG COM was showing 90c will VAG COM be getting it's temp from the same sensor that the guage uses ??? if so does this mean the guage is at fault ?? there was a code on VAG COM that mentioned a sensor short.... when i cleared this the guage came back on again so i would have thought this would be pointing to the common temp sensor problem.... i just dont understand why the guage read nothing but at the same time VAG COM was getting a temp.... the fault code has yet to return even though the guage has still been playing up...

    Sorry for the long post... but i'm needing my motor back ASAP

    Cheers guys... Mark
    #1
  2. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    267
    drop the shocks and the spring will "pop" out with some tweakage. The sender unit has 2 sections in it, one that runs the gauge and one that runs the ECU. The Vagcom reading is seeing the ECU feed.

    Sensor is around £20, make sure you get the seal too
    #2
  3. 666markyboy
    Offline

    666markyboy Active Member

    Joined:
    Mar 17, 2008
    Messages:
    1,123
    Likes Received:
    32
    exellent..... thanks Byzan
    #3
  4. rossbrownlee
    Offline

    rossbrownlee Ross_S4

    Joined:
    Aug 16, 2009
    Messages:
    719
    Likes Received:
    0
    also...
    If you have xenons with self levelling, watch out when dropping the suspension arm as you can break the level sender on the n/s/r.
    #4
  5. 666markyboy
    Offline

    666markyboy Active Member

    Joined:
    Mar 17, 2008
    Messages:
    1,123
    Likes Received:
    32
    Easy when you have a site like this fall back too innit.. :) nipped out after tea tonight and done the drivers side in 20 mins.... gota say though looking at the old spring i think it's been broke for years.... just a tiny bit has broken off the end... couple of inches long if that.... i'll do the otherside tomorrow night after work then i have a trackrod end to do and fingers crossed back for the retest... where's the best place for a new temp sender ?? local parts store is BMS then we have GSF a bit further away or it a stealer part ??

    just a bit worried the cars gonna look like a 70's dragster with new springs on the rear...


    cheers again guys
    #5
  6. builder al
    Offline

    builder al New Member

    Joined:
    Jul 24, 2008
    Messages:
    14
    Likes Received:
    0
    i changed one back in the summer unbolt the rear shock and pull it down put on new spring and just jack it up with so the bolt lines up with the bottom of the shock
    15 mins ,there are photos and detail how to do it that was sent to me like you i didnt have a clue.
    #6
  7. Kingston
    Offline

    Kingston Member

    Joined:
    Jun 2, 2009
    Messages:
    183
    Likes Received:
    0
    My temp gauge played up just took the sender out cleaned it up and put it back in. The one on the engine not radiator.
    #7
  8. 666markyboy
    Offline

    666markyboy Active Member

    Joined:
    Mar 17, 2008
    Messages:
    1,123
    Likes Received:
    32
    Oooo right i might have a look at it then..... i'm at work at the mo so no manual , where abouts on the engine is it ???
    #8

Share This Page