1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Misfire when cold on 1.9TDi

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by connaco, Dec 11, 2009.

  1. connaco
    Offline

    connaco New Member

    Joined:
    Sep 20, 2009
    Messages:
    2
    Likes Received:
    0
    [Dec 11, 2009]
    Hello, I have got a 2001 51 reg Audi A4 with a 1.9TDi engine. The problem I have is that when the car is cold it misfires and then sometimes one of the cylinders cuts out altogether.

    I had a diagnostics run and two problems came back;

    - 16685 P0301 - Cylinder 1 - Sparodic misfire detected
    - 18074 P1666 - Valve for sporadic pump injector cylinder 1-N240: Electrical Malfunction

    Now I have just had the injector on cylinder 1 replaced a week ago as I thought that was the problem but it hasnt made any difference. I dont think it is the injector itself as the car will start to misfire and sometimes recover and run fine, but sometimes the engine warning light will come on (orange triangle with an arrow around it, also comes on when the traction control is turned off) and it will run on three cylinders until I pull over and turn the engine off and then on again and it will run fine for a few minutes then start to misfire again. This continues until it reaches 90 on temperature guage, and then all is fine until I stop and it cools down again!

    Any suggestions what to look at/replace!?!?:banghead:
    #1
  2. Ads

    Ads

    [Dec 26, 2014]

  3. BILKO1
    Offline

    BILKO1 Member

    Joined:
    Sep 1, 2003
    Messages:
    301
    Likes Received:
    1
    [Dec 11, 2009]
    The wiring loom to the injectors is a very common fault, about £35 from stealers.
    #2

Share This Page