1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MFSW problem

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by JDM82, May 25, 2012.

  1. JDM82
    Offline

    JDM82 Member

    Joined:
    Jul 31, 2011
    Messages:
    329
    Likes Received:
    3
    Im currently having a MFSW retrofitted to my 2005 A4. Im getting it done by a professional but we are having a problem. The lad fitting it is on the case but I thought id throw up the question, you never know........ Im sure the lad will come up with the solution but I still may aswell ask.

    The wheel fits perfect and the guy codes it in but the buttons don't work nor do they light up. I have the correct module ( 8E0953549Q) and slip ring (4E0953541) and I already have cruise control fitted.

    The module has been replaced to see if that was the problem, it wasn't.

    The guy checked the wheel in his car and it works fine.

    The next point of interest is the slip ring. The horn works and the air bag light doesn't come, two signs of a faulty/damaged slip ring i've been told.

    Im sure the guy will figure out whats wrong however if anyone on here has had the same problem or has any suggestions, that would be great.

    I'd rather go back to the guy with suggestions and see if anything works.
    #1
  2. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,187
    Likes Received:
    40
    I assume you got a new airbag harness?
    #2
  3. JDM82
    Offline

    JDM82 Member

    Joined:
    Jul 31, 2011
    Messages:
    329
    Likes Received:
    3
    Yeah, the guy did fit a new harness to the back of the airbag.
    #3
  4. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,187
    Likes Received:
    40
    In that case it does sound like the slip ring, you did get the right slip ring? From memory there should be a letter after the part number.
    #4
  5. Wrath
    Offline

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,187
    Likes Received:
    40
    Just checked and you need either 4E0953541A or B as they have the 12 pins.
    #5
  6. JDM82
    Offline

    JDM82 Member

    Joined:
    Jul 31, 2011
    Messages:
    329
    Likes Received:
    3
    Cheers Nathan
    #6
  7. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,237
    Likes Received:
    1,220
    Yeap cant be much more at fault tbh, only items I can think are slip ring & airbag loom, but if he's tested wheel/bag on his car then obviously the loom is fine, so must be ring with an issue.
    #7
  8. JDM82
    Offline

    JDM82 Member

    Joined:
    Jul 31, 2011
    Messages:
    329
    Likes Received:
    3
    He suggested the slip ring so I think that's a good way to go......

    Cheers guys, as always a great help :icon_thumright:
    #8

Share This Page