1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mapped or not???

Cra16v Jul 23, 2013

  1. Cra16v

    Cra16v New Member

    Hey all got my milltek tbe fitted to my 2007 s3 which includes decat but was always unsure weather or not it has been mapped so gave it s power run and it made 279.6 hp at fly with 289ft/lbis this about rite when fitting a full milltek?? It also has a dibilas flow master which was fitted when I bought it thanks craig
  2. Boydie

    Boydie S3 8V DSG VCDS Map User

    What was it making at the wheels?

    IMO your car is not mapped. The full turbo back exhaust will allow more air flow and is less restrictive. Accompanied by the intake you will see an increase in BHP.

    Now, to get the most of the mods and the car you need to map the car. However, you will see misfires and possible coil pack failures so you will have to buy a high pressure fuel pump (HPFP) and have the car mapped to suit.

    After that, you could then install the RS4 fuel valve reg to help fuel flow.

    Personally, I would sell the dbilas and get a AMD/ITG/REVO intake as they have come on a lot since 2007 when the dbilas was first released.
  3. Revo Steve-W

    Revo Steve-W Well-Known Member


    You should now be looking at Stage 2 mapping, to compliment the Hardware and certainly make the most of your vehicle.

    Please see link below and don't forget there is currently a 20% saving on Revo software!!

    Boydie likes this.
  4. Boydie

    Boydie S3 8V DSG VCDS Map User

    Steve - I am revo 2+ and personally I didn't see any point of Stage 2 due to misfires hence why I went 2+ with the extra map and HPFP.
    Revo Steve-W likes this.
  5. DJ-S3

    DJ-S3 Active Member

    I'd say definitely not mapped. Mine at stage one was 315bhp. But I had full system exhaust, ITG, uprated intercooler and hpfp. That was with revo.
  6. RedDejavu

    RedDejavu Well-Known Member

    In my opinion your car is mapped with revo stage 2 but someone has change the settings via sps to make B/T/F default values of '0'

Share This Page