1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Major loss of power on Motorway - 1.9 TDI

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Blue_Thunder, May 12, 2011.

  1. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,708
    Likes Received:
    9
    My sister phoned me panicking yesterday as her car decided to lose power on the motorway. She said she had been travelling along at 90, then all of a sudden it lost power and wouldn't go quicker than 75. She called a couple minutes later to say even with her foot to the floor it had slowed down to 60.

    There were no engine warning lights, temp gauge looked fine and there were no odd smells. I got her to pull off the motorway and turn the engine off to hopefully clear what I was hoping would be limp mode. That seemed to do the trick and she was able to drive home as normal.

    Does this sound like the symptom of limp mode on the 1.9TDI? If so, what are the common causes on these motors? I'm guessing it will be a crappy Bosch sensor or a MAF that's thrown up a fault, but unfortunately i'm a couple of hundred miles away and can't Vagcom it.

    Any help would be appreciated.
    #1
  2. roman3000
    Offline

    roman3000 Member

    Joined:
    May 14, 2010
    Messages:
    330
    Likes Received:
    3
    It sounds like limp mode, could also be the turbo from my experience. Put some Innotec Turbo Cleaner through it and should be better.
    #2
  3. welshwoody
    Offline

    welshwoody Member

    Joined:
    Feb 19, 2010
    Messages:
    392
    Likes Received:
    1
    Sounds like the MAF sensor if its anything like what happened to my previous A3, which is what it sounds like. Mine was like driving a diesel but without the turbo, could bearly get to 70 MPH and if Istarted to go uphill, with a car load of people, I was screwed.
    #3
  4. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,708
    Likes Received:
    9
    Thanks for the input guys.

    I'm not at all worried about it being the actual turbo. This defo sounds like the ECU pulling back. But even if it wasn't requesting boost from the turbo, I would still expect a 1.9 diesel to be able to do more than 65 with no boost. That's more the concern.

    Anyone know what the going rate is for the MAF for these? She won't be happy if it's anywhere near the price of the RS4 MAF in mine!
    #4
  5. welshwoody
    Offline

    welshwoody Member

    Joined:
    Feb 19, 2010
    Messages:
    392
    Likes Received:
    1
    Mine was about £90-100 around a year ago. When mine went it was like it had no turbo at all and I struggled to get 70 out of her, really struggled. Mine was a 1.9 too.
    #5
  6. devonmikeyboy
    Offline

    devonmikeyboy As far from JBS as possible !

    Joined:
    Feb 8, 2007
    Messages:
    1,246
    Likes Received:
    7
    Nope when in limp mode the ECU restricts engine power as limp mode is a safety feature programmed into the ECU to stop engine damage. Car could have gone into limp mode for many stupid reasons but MAF is unlikely to be one of them. Usual reason is the turbo over boosted slightly for some reason. Most of the time after switching the ignition on/off the car will drive like normal and not go into limp mode again.
    #6
  7. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,708
    Likes Received:
    9
    Are these engines prone to boost leaks?
    #7
  8. welshwoody
    Offline

    welshwoody Member

    Joined:
    Feb 19, 2010
    Messages:
    392
    Likes Received:
    1

    Would the car do 60-75 in limp mode though?
    #8
  9. Orts
    Offline

    Orts Member

    Joined:
    Mar 22, 2011
    Messages:
    109
    Likes Received:
    0
    Same thing happens with mine whenever i go about 2 hours of constant motorway driving, no warnings just the turbo goes and it will hold upto 80mph but like you guys it is slow getting there with very little acceleration. Heard guys on here talk about the turbo pipes having cracks or a pressure build up but so far I've not investigated mine, turning the engine off and on, even while sat at a red light clears it and I get another 2 hours motorway driving before it happens again. Never happened in any other situation and I don't do that much constant driving on the motorway. Mine is an 05 2.0tdi. Be interested if you find a cause though!
    #9
  10. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,708
    Likes Received:
    9
    It's unlikely that a mechanical fault such as a knackered turbo could be resolved by turning the engine off and on again though. It surely must be the ECU spitting it's dummy out for some reason and choosing not to request boost.

    From my experiences with my S4, the only time i've had the car in actual limp mode has been either due to dodgy sensors (EGT and Lambda) or because the long term fuel trims reached a certain level. The latter occured when my fuelling was being pulled back significantly by the ECU. The culprit ended up being melted fuel lines causing the fuel pressure regulator to become blocked, therefore the fuel pressure in the fuel rail was too high. I know nothing about diesel engines, so not sure if they even have these things, but I am pretty certain it will be something simple like a sensor or dodgy fuelling, etc.
    #10
  11. jameshughes1974
    Offline

    jameshughes1974 Member

    Joined:
    Nov 9, 2005
    Messages:
    112
    Likes Received:
    0
    Its very likely that it has a stuffed turbo
    Going into limp mode on the motorway(and it being ok on restart) is a classic Audi symptom of a turbo diesel that has over boosted.
    restarting it fixes it for a while.
    Maf sensors when they go are stuffed regardless of how many times you restart the car.
    Its very likely that the vnt vanes are sooted up.
    Innotec or any other cleaning solution is no substitute for getting the turbo of the car.
    But before all that get the fault codes out of it with VCDS
    #11

Share This Page