1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lumpy 2.6 V6 Cabriolet 1994-95

Discussion in 'Classic Audi Forum' started by filemakers, Jan 31, 2009.

  1. filemakers
    Offline

    filemakers New Member

    Joined:
    Jan 31, 2009
    Messages:
    3
    Likes Received:
    0
    [Jan 31, 2009]
    Hi Everyone, Hoping someone can help me
    (sorry for double post in Vag by mistake)

    I have a M reg (94-95) Audi A4 Cabriolet 2.6 V6.

    I have in the past have the same engine in a A6 of the same year, and it was really smooth, My A4/80 cabrio however is really lumpy, its hard to explain but it isnt right.

    I have put a blink sensor on it and it comes in at a 23-23 we think its pretty hard to catch but we decieded on 23-23,, we ran it a few times, looked up the code and it showed a Knock sensor,, the Car shows as haveing 2 of these, so both were replaced, however the car is still the same.


    I have since also tried it on a Vag sensor and it was also showing knock sensor, Still no joy after a reset.

    I am thinking maybe a problem with the ECU, I can find loads about 2nd hand for the A6 2.6 v6 but not the A4, can anyone tell me are these the same, or if they are different, is it so slight that maybe a superchip upgrade to may give me a working A4 one?

    If not the ECU has anyone else had this, Just so's you know, Changed HTC leades, Compressions Good, Plugs replace, Timing Not missing, However timing missing is what it feels like sometimes.

    Thanks

    Andy

    :redrs4:
    #1
  2. Ads

    Ads

    [Dec 25, 2014]

  3. filemakers
    Offline

    filemakers New Member

    Joined:
    Jan 31, 2009
    Messages:
    3
    Likes Received:
    0
    [Feb 4, 2009]
    It seems you are all drawing a blank,, does anyone out there know if the ECU's on the A6 2.6 V6 is the same as the same engine on the A4?
    #2
  4. audi5e
    Offline

    audi5e Member

    Joined:
    Jun 14, 2004
    Messages:
    809
    Likes Received:
    0
    [Feb 9, 2009]
    The code may be thrown because the knock sensor is picking up detonation/knocking which is actually caused by something else??

    Maybe an air leak somewhere on the inlet side??
    #3

Share This Page