1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Low oil level warning!!!

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by Keggers, Nov 9, 2013.

  1. Keggers
    Offline

    Keggers Member

    Joined:
    Sep 2, 2012
    Messages:
    45
    Likes Received:
    0
    [Nov 9, 2013]
    Hi there, I only just fixed my coolant sensor then a few days later I now have the low oil level indicator coming on straight after I start the car. I've checked the oil level and slightly topped it up but the indicator stays on!! My book says there is also a warning for oil level sensor when it's faulty so I'm not sure if its the sensor or not.

    Anyone got any ideas?

    Thank you.
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. wesmaster
    Offline

    wesmaster Member

    Joined:
    Apr 22, 2012
    Messages:
    299
    Likes Received:
    18
    [Nov 9, 2013]
    I had this, fitted a new level sensor and still got message, disconnected battery for 5 mins and was sorted!
    A slight glitch with instrument cluster.
    #2
  4. Keggers
    Offline

    Keggers Member

    Joined:
    Sep 2, 2012
    Messages:
    45
    Likes Received:
    0
    [Nov 9, 2013]
    Brill, I'll try that tomorrow then, thanks.
    #3
  5. Keggers
    Offline

    Keggers Member

    Joined:
    Sep 2, 2012
    Messages:
    45
    Likes Received:
    0
    [Nov 10, 2013]
    Went out in car last night and seems to have self rectified its self!!
    #4
  6. adamss24
    Offline

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    3,361
    Likes Received:
    175
    [Nov 14, 2013]
    Usually the micro switch built in the bonnet lock is faulty, there's something in the code that stipulate one needs to lift the bonnet and check the oil level then it goes off ! As above, disconnecting the battery has a similar effect as it's resetting the gauge...
    #5

Share This Page