1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Low maf readings, timing prob,...logs inside

Discussion in 'A3/S3 Forum (8L Chassis)' started by Chlippo, Mar 25, 2014.

  1. Chlippo
    Offline

    Chlippo Member

    Joined:
    Apr 17, 2010
    Messages:
    675
    Likes Received:
    13
    [Mar 25, 2014]
    So here we are again :) another attempt to have a decent remap.
    AMK engine, Beachbuggy hybrid turbo, fmic, 3" downpipe decatted, exhaust manifold.

    Finally fitted the Mitsubishi evo9 intercooler. Huge improvement over the chinese one. iat are around 37-40, and they get up to 50 when the car its pushed hard, until now I have never seen it past 50. Its pretty much hot here so I guess those IAT are ok!
    Oh and for the record, I couldnt fit the crash bar after the evo9 Intercooler.

    Another attempt with another map (no custom tuners available in my country, map done by an amateur/fanatic friend so plz guys no harsh feelings, If i could have bought a custom map I would have done it instantly)

    The car runs good, power feels good, but it feels low on torque. I am not getting the timing requested.
    Bill once told me I have to get a fix for my low maf readings, but its been triple checked, maf is fine. Maybe it just the hot air? What can cause me low maf readings?

    Here is some logs that was done yesterday, they are not perfect and not to redline but there was no point getting to redline as I was already seeing something wrong with maf readings and timing.

    Tomorrow we will try a different airbox setup see how it goes.

    [​IMG]

    [​IMG]
    #1
  2. Ads

    Ads

    [Dec 27, 2014]

  3. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,554
    Likes Received:
    793
    [Mar 26, 2014]
    throttle closing after 6k... or you?
    #2
  4. Chlippo
    Offline

    Chlippo Member

    Joined:
    Apr 17, 2010
    Messages:
    675
    Likes Received:
    13
    [Mar 26, 2014]
    Its throttle closing. Thats what I am trying to figure out and solve.

    As you said to me before, "under reading maf will offset what the cars doing fuel wise and load wise.. if under reading it will be running in a lower load position on the map tables"

    I am doubting that its related to my low maf readings, but there's nothing there. The maf is Ok.

    iirc when I logged the car on the stock map, my maf was reading 140-150. Could it be that due to Heat or anything else that's resulting that we here in Lebanon read lower maf readings than you ?
    #3
  5. Chlippo
    Offline

    Chlippo Member

    Joined:
    Apr 17, 2010
    Messages:
    675
    Likes Received:
    13
    [Mar 28, 2014]
    switched with 2 others used maf's and I get the same result. Could they be all faulty/tired?

    I get the impression that if I don't get the maf reading correct there's no point looking into other tuning issues
    #4

Share This Page