1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

loss of power audi a4 2.5 tdi quattro

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Johnboymason, Apr 3, 2013.

  1. Johnboymason

    Johnboymason Member

    Joined:
    Nov 19, 2012
    Messages:
    73
    Likes Received:
    0
    can anyone help me, im losing power on my 51 plate audi 2.5 tdi quattro, just replace water pump, timing chain pullys, thermostat, engine temp cencor, i can be driving along and my foot will be flat to the floor and it just creeps up to 2000 revs, but then 5 mins later the power comes gushing back :s ive checked boost pipes and all seem fine, no faults codes or anythink anyone any ideas please
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. RobMorris

    RobMorris Member

    Joined:
    Sep 9, 2011
    Messages:
    540
    Likes Received:
    10
    Sounds like limp mode - mine done it a couple of times after I ragged it - but once I turned the ignition off and on it was OK again?
     
  4. Johnboymason

    Johnboymason Member

    Joined:
    Nov 19, 2012
    Messages:
    73
    Likes Received:
    0
    well when am driving along say in second and a go to put my foot down theres just nothink there and it slowly climbs up the revs, but 5 mins later when ive still be driving the power comes back out of no where :S
     
  5. Johnboymason

    Johnboymason Member

    Joined:
    Nov 19, 2012
    Messages:
    73
    Likes Received:
    0
    when i put my foot down and change gear it also makes a chatter noise as if pipe off airbox and mass air flow is dissconnected :S
     
  6. jordanjcruiser

    jordanjcruiser New Member

    Joined:
    Apr 6, 2015
    Messages:
    3
    Likes Received:
    0
    Hi john I recently purchased the exact same model audi A4 b6 2.5tdi but automatic. I am experiencing the exact same problem. Please let me know what u did. If I put my foot down nothing. Then later on it just works normally again when it gets to about 2500 revs. Iv been to so many machanic but I get different stories please help. At first I thought it was the clutch plate got it changed but same story. Please
     
  7. desertstorm

    desertstorm Well-Known Member
    Audi A4

    Joined:
    Nov 21, 2013
    Messages:
    2,524
    Likes Received:
    864
    Sounds like an N75 issue with a lack of vacuum to the VNT actuator on the turbo. when it gets over 2K RPM does it run better ?. Try logging the boost / MAF outputs and see whats going on when the fault occurs.

    karl.
     
  8. jordanjcruiser

    jordanjcruiser New Member

    Joined:
    Apr 6, 2015
    Messages:
    3
    Likes Received:
    0
    hey there yes it does run better after 2k. Actually it boosts then if I let go of the gas n try again same thing happens
    it's very irritating especially if m in traffic.
     
  9. AlexGSi2000

    AlexGSi2000 Well-Known Member
    VCDS Map User

    Joined:
    Feb 14, 2012
    Messages:
    1,441
    Likes Received:
    191
    I would begin by checking the following areas/items;
    - MAF
    - Turbo VNT mechanism - clean.

    The fact that the power comes back out of the blue rules out boost pipework / vac lines for me - if it was constantly down on power then they would be an area to check thoroughly.

    Do you have access to VCDS? If so, you can log boost pressure, air intake volumes, fuel injection quantity - this can help drastically when trying to identify a problem that isnt obvious.
     
  10. jordanjcruiser

    jordanjcruiser New Member

    Joined:
    Apr 6, 2015
    Messages:
    3
    Likes Received:
    0
    Thanks a lot mate. I will take in today and let my machanic do all that. Cause m lost lol. Thanks a lot. Gdday
     

Share This Page