1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Loss of power and black smoke

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Athomas, Sep 18, 2013.

  1. Athomas
    Offline

    Athomas New Member

    Joined:
    May 11, 2013
    Messages:
    1
    Likes Received:
    0
    [Sep 18, 2013]
    Recently while driving up mortorway, realised heaters plug light on dashboard was flashing , at that moment engine response felt sluggish and black smoke started was coming out exhaust when I pushed the throttle all the way.. Got to a garage where he put a diagnostic on it but didn't give any faults (by this time heater plug light had gone out).....the car has hardly any power untill 3000rpm where the turbo kicks in and it's away like a scolded cat (turbo usually came in much beforen3000rpm) all while pumping black smoke out the exhaust..I've had a dpf delete and a remap(a4 2.0 tdi 170 07 plate)....mechanic has looked at it and got it back to standard software so he could diagnose it properly but still giving no faults.... He seems to think maybe turbo although he inspected it and thought it looked ok, or injector problem ( car has had injector recall less than 18 moths ago)....

    Sorry about the long post but not sure what to do next , any suggestions would be welcome....thanks
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. sewell10
    Offline

    sewell10 Member

    Joined:
    Dec 19, 2010
    Messages:
    225
    Likes Received:
    10
    [Sep 19, 2013]
    Change your fuel filter first, injector fault possible
    #2

Share This Page