1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

loss of power 2.5 tdi quattro

Discussion in 'A4/S4 forum(B5 Chassis)' started by s4mmie, Oct 3, 2010.

  1. s4mmie
    Offline

    s4mmie New Member

    Joined:
    Oct 3, 2010
    Messages:
    6
    Likes Received:
    0
    [Oct 3, 2010]
    hi guys new to this but need some help.got 2.5 tdi quattro avant 92k good condition,had a loss of power,would"nt rev over 3000 revs.local garage i use said oil pump,turbo and cats need replacing.first off does his diagnosis seem correct and secondly at approx £1800 should i get it done.dont seem to be a lot of a4 quattro around and i love the car so any help would be welcome cheers
    #1
  2. Ads

    Ads

    [Dec 18, 2014]

  3. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,845
    Likes Received:
    350
    [Oct 3, 2010]
    That diagnosis seems a bit random and made up lol.

    Not sure whats actaully wrong with it, but if it was the oil pump, turbo and cat all at the same time you would be rather unlucky!
    #2
  4. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Oct 3, 2010]
    waahaa thats the biggest load of rubbish I ever heard someone tell a poor customer! My god, never go back there, even for screen wash fluid mate, they'll have the milk out of your tea and the fillings out of your teeth next. Oil pump, turbo and cats?? Are they on drugs? £1800?? :laugh:

    That would warrant a smack in the mouth round some parts! Pure bare faced, dumb ass cheek mate, honestly I cant believe anyone would try that on another person. The truth is, they have no idea, and have suggested changing 3 major and expensive bits of kit, when in fact, it will possibly not even fix the problem.

    Some questions,

    what year is your car mate? When does it stop revving past 3k, up hills in 4th, or all the time? ie any gear any road?

    Do you have a diesel leak from under the engine when its sitting?

    When was the fuel filter last replaced?

    Has the turbo actuator or wastegate been fiddled with or a tuning box fitted?

    Does it start and idle well?

    Does it sound any different after it started doing this behaviour?

    Gimme some more info and I will give you a proper list of cheap things to check and narrow it down. It could be something as simple as a cracked rubber vacuum tube.....or a MAF sensor....or any number of non-expensive things. But lets gather the facts first :)
    #3
  5. s4mmie
    Offline

    s4mmie New Member

    Joined:
    Oct 3, 2010
    Messages:
    6
    Likes Received:
    0
    [Oct 3, 2010]
    apparently oil in turbo and cat?
    #4
  6. s4mmie
    Offline

    s4mmie New Member

    Joined:
    Oct 3, 2010
    Messages:
    6
    Likes Received:
    0
    [Oct 3, 2010]
    its a 99t plate runs/tickover fine,had a bad oil leak which many different garages (including audi dealer) failed to fix.revs freely when not in gear, but general driving wont go over 3000 rev in any gear.had air mass sensor replaced 1ooo miles ago.garage who diagnosed fault comes recommended from people who know and i have used him before.he has latest bosch dianostic kit which failed to pick up any fault codes which confuses me even more
    #5
  7. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Oct 3, 2010]
    wouldnt stop it revving past 3k mate, oil in the turbo and cat, unless its the whole engine contents, is normal for a coal-burner, the turbo bearings wear slightly, oil seeps past and gets blown down the exhaust, but the exhaust gas temps under load can hit 1200 deg C so any oil gets burned off and doesnt build up much levels.

    You need to get the car scanned by a vag com user for codes, and see what the car's computer says.

    Can you answer the other questions?

    EDIT posted after you replied, gimme a minute to digest the post :)
    #6
  8. s4mmie
    Offline

    s4mmie New Member

    Joined:
    Oct 3, 2010
    Messages:
    6
    Likes Received:
    0
    [Oct 3, 2010]
    car has been serviced every 12 mths (5000 miles) very noisy engine since i bought it 3 years ago but no power problems till now. full service history with the car and hpi checked no mention of any major engine/turbo work
    #7
  9. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Oct 3, 2010]
    ok, usual suspects are, MAF (unplug it, if it revs over 3k, theres the problem), N75 boost control valve, can cause this, sticking VNT turbo actuator or vanes, sooted up intake and turbo (cleanable), a clogging fuel filter (they may not have actually replaced it during the service), and injection pump timing will cause this if its off (if its not a PD engine), and btw bosch diag kit cant necessarily read vag codes, you need vag com. Bosch will only read the generic OBD codes which only show if a sensor has failed completely, not if its giving wrong readings, only vag com and a laptop can see that.
    #8
  10. beachbuggy
    Offline

    beachbuggy Well-Known Member

    Joined:
    Jan 27, 2010
    Messages:
    1,784
    Likes Received:
    142
    [Oct 4, 2010]
    Almost guarentee vanes on the turbo have seized due to carbon build up.

    Common issue, had in on my current 2.5 quattro.

    Very easy to diagnose. Remove engine cover and the heat shield from the turbo. Get someone to start the car, while you watch the actuator rod, as the car starts you should see the rod move up into the actuator valve. If it doesn't move or only moves a little then that's your problem.

    Fixing, fortunately on these engines is pretty easy as the turbo can be removed in 10 minutes, you can then remove the exhaust housing, cartridge with the vanes, soak in Diesel for 48 hours, clean, reassemble and job should be done.
    Last edited: Oct 4, 2010
    #9
  11. adamss24
    Offline

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    3,523
    Likes Received:
    194
    [Oct 4, 2010]
    If it helps at all, the cat is not required on a diesel and quattro has 2 of them just to keep the emissions down. I suggest you remove them all toghether and break the monolith inside with a long rod and hammer. Mine has no cats whatsoever and passes MOT tests for a few years now... If you wanna diagnose a blocked cat then take the cast section from the turbo to manifold and see if it drives any better, dont drive for too long as the hot gasses will melt things...As above, my money are on a plugged cat, faulty MAF (fit a genuine one in there) or a VNT mechanism problem. I would also block the EGR valve while at it and clean the crud from the intake pipe.
    #10
  12. PW-Motorsport
    Offline

    PW-Motorsport Member

    Joined:
    Jun 13, 2006
    Messages:
    396
    Likes Received:
    0
    [Oct 4, 2010]
    Get the pump timing checked.

    Check to condition of cam belts and pump belt.

    Take it to a garage that has a good knowledge this engine.....
    #11
  13. s4mmie
    Offline

    s4mmie New Member

    Joined:
    Oct 3, 2010
    Messages:
    6
    Likes Received:
    0
    [Oct 4, 2010]
    done that, main turbo oil seal failed,oil sucked into cats completley blocking them hence loss of power.lack of oil for turbo so increased wear so knackerd turbo and cat
    #12
  14. s4mmie
    Offline

    s4mmie New Member

    Joined:
    Oct 3, 2010
    Messages:
    6
    Likes Received:
    0
    [Oct 4, 2010]
    unfortunatley done that ,same problem but specialist has looked at the turbo it is badly worn due to lack of oil for a long time,but he has agreed to do a deal on an exhange basis £250 exchange and £125 for nos cats he2s had lying around
    #13
  15. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Oct 4, 2010]
    thats not so bad mate, you are well unlucky there to hit that problem, but thinking about it, usually the oil goes into the intake side of the turbo and the engine "runs away" on its engine oil till it goes bang, as the oil is dropping rapidly and the motor is revving its tits off, with little way of stopping it quickly enough. Cats and a turbo are easier than a new engine eh.
    #14
  16. adamss24
    Offline

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    3,523
    Likes Received:
    194
    [Oct 5, 2010]
    Your specialist is taking the mikey out of you ! If the exhaus seal had gone then it would have smoked worse than the orient express and as evilscot has pointed the seal most of the time blows on the intake due to bloked breather wich will lead to engine runaway ! Yeah right he's got 2 cats and a spare turbo lying around ! There are no more honest mechanics left in the world ?
    #15
  17. evilscotsman
    Offline

    evilscotsman Space Cowboy

    Joined:
    May 1, 2008
    Messages:
    1,350
    Likes Received:
    12
    [Oct 5, 2010]
    gotta admit mate that if you searched this forum long and hard, you wont find anyone else this has happened to (cats and turbo knackered from oil) and that in itself should ring alarm bells.

    We all chat with each other and loads of other audi folk, some experts some just drivers, but across forum world, info spreads fast and wide. A car fault cant hide these days, it goes round like wildfire and we all know about it. Thousands of people, all driving the same cars and hitting the same faults. Think about it, that pool of information is deep and unless your "expert" is a trained motor engineer (audi / vw preferably) with a conscience then you need to take what they say with a pinch of salt mate. We have nothing to gain from mis-advising you, but they do.

    Usually when some "mechanic" or "expert" states something we know isnt true to a new member, or that we have never heard of, the member will usually return much later with all the "expert"-suggested bits changed and the fault still there, and we usually end up at our original conclusions, ive seen it many many times on here.

    get a second opinion in person from a qualified motor engineer or 2 round your way, and if they agree with yer man, then fine, i'll eat my hat ;)

    Hope you get to the bottom of it though mate.

    Also think of this.....exhaust pressure is powerful, an engine is a fantastic compressor, pushing 400psi cylinder pressures at times, then that hot expanding gas is pumped down the pipe and out......what happens if you block that pipe, with say, a clogged cat, then drive it on the road at 3000 rpm?, the same huge pressures would be developed in the blocked section of exhaust, and something would have soon gone pop in the motor or the primary pipework, no engine can sustain an exhaust blockage for long without bursting the pipe somewhere else or being so sluggish you would never get to any speed,

    but yours drives ok otherwise, and just wont rev over 3k???

    c'mon think about it.
    Last edited: Oct 5, 2010
    #16
  18. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,845
    Likes Received:
    350
    [Oct 5, 2010]
    Lol, the £250 exchange price for the turbo is far too cheap, so its either chinese rubbish, or hes just charged you £250 to give your old one a scrub with a wire brush and a decoke and then refitted it.

    The engines are pretty rare in the grand scheme, so the chances of him just happening to have some cats laying around seems minimal to me. Hes probably just pulled off yours and gutted them out, if hes done anything at all.

    I've seen blocked cats on 1.8T's and as evil says, they're completely gutless, struggling to get upto even 50 or 60mph.
    #17
  19. foursprungdugtechnique
    Offline

    foursprungdugtechnique Member

    Joined:
    Jan 29, 2011
    Messages:
    281
    Likes Received:
    22
    [Feb 27, 2011]
    Some useful stuff on this thread. I have a 2.5tdi (not quattro) and mine struggles to get 3500. My old turbo was letting oil through, replaced it with brand new Garrett unit £555 + VAT and carriage.
    Tried MAF, EGR, boost solenoid, tested for boost leak (no boost leak in intake side) everyone still seems stumped. The only other thing could be cat or vacuum leak. There is a noise when it starts to boost like a quiet shreak, this has been happening since before the turbo was changed, so not a gubbed turbo.
    To be honest my fuel filter could do with a change, there is dampness around the fuel pipe where it goes from below the car to the engine bay. More options, might have a look at knocking the cat out, it has 115000 on original exhaust.
    #18

Share This Page