1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Loosing boost after a while on my S3

Discussion in 'General Technical / How To' started by Beenie, Apr 29, 2008.

  1. Beenie
    Offline

    Beenie Member

    Joined:
    Apr 12, 2008
    Messages:
    62
    Likes Received:
    0
    [Apr 29, 2008]
    I dunno whats up with my '01 S3 but if I give it some beans it feels like the turbo just gives up, the dump valve is usually really loud but after some thrashing it'll give out one long blast of air, then it feels like the car is running less than half the boost. So I stop, turn the engine off turn it back on and it's all good. It's got me very confused. Has this ever happened to anyone before?

    I'm thinking dodgy dump valve? maybe sticking open?
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. Beenie
    Offline

    Beenie Member

    Joined:
    Apr 12, 2008
    Messages:
    62
    Likes Received:
    0
    [May 1, 2008]
    ok did a little "messing around" tonight, took the cover off the engine to have a nose around, found a little "thingy", possibly and electronic amal valve? anyway I thought, lets unplug it and see what happens, and bingo!! started the car up and drove exactly how it does as I've explained above, stopped reconnected it and it was perfect again!
    So my question is, what is this part??

    [​IMG]
    #2
  4. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,597
    Likes Received:
    274
    [May 1, 2008]
    That is your N75 ,AKA Boost control valve
    #3
  5. Beenie
    Offline

    Beenie Member

    Joined:
    Apr 12, 2008
    Messages:
    62
    Likes Received:
    0
    [May 2, 2008]
    nice one, well I've just ordered a n75j valve from vag parts, see if that does the job!
    #4

Share This Page