1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Loose connection on Indicator

Mikebabs1 Jun 6, 2005

  1. Mikebabs1

    Mikebabs1 Member

    185
    1
    16
    My front-left indicator keeps giving up on me and annoying me with the DIS beeping and double-speed indicating. It's done it ever since I've had the car and just meant I have to pull out the light unit and re-tighten every 2 or 3 months.

    Ever since my neighbour reversed into the front of my car a few weeks back, its now happening all the time. The last straw was on Sunday when I tightened it up, drove down to the shops and it went again after 2 minutes!!

    Is there anyway I can replace the bulb holder thing which screws into the light unit myself (which is presumably the problem), or do I have to take it into a dealer?

    Cheers

    Mike
     
  2. mjsewell

    mjsewell Member

    74
    0
    6
    I've been having exactly the same problem and have literally just got back from the local dealership.

    They replaced the bulb and the mechanic said that the contacts were slightly mis-aligned and he bent them slightly, to make a better connection. Cost £17 but I couldn't face the grief of trying to access the back of the headlight unit.

    Might be worth trying on your car.

    Good Luck.

    Matthew
     
  3. dstech

    dstech Member

    247
    0
    16
    Yes, my guess is that it's the contacts and the fix that Matthew posted is probably what needs to be done to your headlight too.
     

Share This Page