1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Long time lurker with problem that's driving me bonkers - central locking

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by _adam_, Jun 11, 2013.

  1. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 11, 2013]
    Hi,

    Not really a VAG man but I've owned my A4 for a few months now and slowly been changing things to get it to a standard that I'm happy with but I've got a locking issue that's got me stumped.
    Ive been browsing threads to try and solve it but to no avail, basically the car keeps locking itself every 30secs but could be as long as 15min until the battery's flat over a couple of days. Also the car won't sleep as the warning triangle pulses constantly when it's locked.

    What I've done
    1. Checked door looms and removed and repaired both front ones
    2. Inspected CCM and alls dry with no sign of water ingress.
    3. Swapped drivers door module
    4. New battery
    5. Gone mad
    6. Vagcom showed no comm with drivers door but loom repair sorted that. All doors report shut and locked


    Any ideas???

    Heres the offending possessed car

    [​IMG]
    Last edited: Jun 12, 2013
    #1
  2. Ads

    Ads

    [Sep 18, 2014]

  3. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    776
    Likes Received:
    8
    [Jun 11, 2013]
    Vagcom should reveal the fault which could be the door lock which is not registering shut when it should.However I have experienced Vagcom failing and that's when problems really start
    #2
  4. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Jun 11, 2013]
    2. Inspected CCM and alls dry with sign of water ingress


    could still be this causeing the problem if it was wet at one time.
    #3
  5. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 12, 2013]
    Apoligies typing error on my part theres NO sign of water anyhere it all dry as a bone including the bulkhead.

    Im gaggin to get the car mapped and a exhaust chucked on but this needs solving first before i put the car on the road :(
    #4
  6. AlexGSi2000
    Offline

    AlexGSi2000 Well-Known Member VCDS Map User

    Joined:
    Feb 14, 2012
    Messages:
    1,196
    Likes Received:
    118
    [Jun 12, 2013]
    Deffo a wiring issue this.
    If it keeps locking after 30 seconds then the control module isnt registering that a door has been opened. (accidental unlock safety feature)
    Have you repaired the rear door looms? the same issue happens here, I need to do mine.
    #5
  7. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 12, 2013]
    A door has been opened ?

    It locks as the car is stood with the doors shut and alarm armed. I've inspected the rear looms and all seem ok one tiny split in a wire but that was it. I think i might strip them out completetly like i did the fronts.

    The locks cycling is very random it cound be 30 sec could be 10sec could be 10 mins if you see what i mean. Just sits there randomly locking the doors.
    #6
  8. dualmono21
    Offline

    dualmono21 Well-Known Member

    Joined:
    Dec 9, 2006
    Messages:
    1,041
    Likes Received:
    59
    [Jun 12, 2013]
    the hazard warning light on my seat leon started doing this and cycling the central locking and flashing the lights as if the alarm was getting an indication to go off
    in the end i changed the hazard warning switch and all was well
    im aware its not the same car but is it possible to remove the hazard switch and see if it still does it ???
    #7
  9. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 12, 2013]
    Never really thought it could be that but i'll try it tonight. Cheers for the heads up.
    #8
  10. Ian2012
    Offline

    Ian2012 Active Member

    Joined:
    Oct 28, 2012
    Messages:
    443
    Likes Received:
    26
    [Jun 12, 2013]
    had a hazard switch prob on an a3 one time caused a lot of wierdness, recently my passat has had water in the ccm (under thre passenger carpet dumb place to put it imo) that caused the left side indicators to come on permanently thus flat battery, after 3 hrs worth of solder and a re program with vcds the car seems touch wood to behave
    #9
  11. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 12, 2013]
    Just tried the hazard switch disconnected still locks itself. Weird thing is when it locks itself it doesn't arm the alarm system just locks the doors.
    #10
  12. dualmono21
    Offline

    dualmono21 Well-Known Member

    Joined:
    Dec 9, 2006
    Messages:
    1,041
    Likes Received:
    59
    [Jun 12, 2013]
    do you have anyone local who you can temporarily swap the part for theres ?
    #11
  13. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 12, 2013]
    Would be nice to try a ccm on the car before I start chasing wiring faults I'm in chesterfield Derbyshire if anyone's local an up for it. I don't mind buying one if I know I'm spending £200 to cure it !!
    #12
  14. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 15, 2013]
    So as I was given an hour off I decided to put my mind to rest about water ingress I decided to get the hose and blast the bulk head and make sure it is draining properly.
    Water was draining nicely from the centre so I decided to give the cabin filter area ALOT of water to see if any made it through, to be fair for the amount of water I blasted at it only a minimal amount made it through.

    [​IMG]

    I stripped out the ccm and double checked for any damaged and it clean as it could be. I even opened it up to check the pcb for dry joints etc and it looks perfect.

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    I even stripped the loom back to the bulkhead to look for any corrosion and no sign at all, so I'm back to square one and off to strip the rear door looms out next to see if I can find a fault 😞
    #13
  15. crazy88
    Online

    crazy88 Loving the anonymity

    Joined:
    Nov 26, 2009
    Messages:
    4,819
    Likes Received:
    393
    [Jun 15, 2013]
    Yeah, i'd say that CCM has not had water ingress, looks perfect inside. And no obvious blown components on the PCB?

    Hope you find the issue mate, it's an odd one!
    #14
  16. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Jun 15, 2013]
    anymore codes come up ?
    #15
  17. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 15, 2013]
    Not scanned it recently ill drop it on again tomorrow.

    Nothing obvious on the pcb and the water only made it down there cos I forced it down there. Could do with someone that's a bit handy with vagcom as I'm only really looking at the basics if anyone's local ish and fancies some beer tokens (Derbyshire)
    #16
  18. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Jun 15, 2013]
    im in sheffield if you want me to plug it in and have a look
    #17
  19. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 15, 2013]
    That'd be great if you could, I could pop up whenever suits you I'm only in chesterfield. If you could pm me your number and ill get in touch.
    #18
  20. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Jun 15, 2013]
    07552111073
    txt me tmoro and ill meet up with you
    lee.
    #19
  21. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 17, 2013]
    Will do cheers.
    #20
  22. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Jun 18, 2013]
    had adam over tonight only code is 01336 - Data Bus for Comfort System: Single-Wire Operation
    all moduals etc seem to be ok
    what the car does is when the door doors are shut left unlocked.
    around 30 seconds when the clocks and light shut down the doors lock (alarm does not arm)
    then around every 30 seconds it locks again (never unlocks)

    als when locked with fob alarm arms then relocks again and again

    any ideas ? NHN think this is in your field ?
    #21
  23. dualmono21
    Offline

    dualmono21 Well-Known Member

    Joined:
    Dec 9, 2006
    Messages:
    1,041
    Likes Received:
    59
    [Jun 19, 2013]
    bez

    just checked my records and that fault code seems familiar
    i had 01336-37-10 faulty intermittant
    turned out it was one of the coding settings on the instrument cluster which had basically forgotten what it should be
    i recoded it and all was fine from there onwards

    hope this helps mate
    #22
  24. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 20, 2013]
    Ive isolated this to the passenger front door last night after disconnecting door looms and then try to arm the alarm. With the passenger front disconnected the car goes to sleep and doesnt try locking!!! Happy isn't the word!

    I'll pull the door to pieces and go from there.
    #23
  25. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Jun 22, 2013]
    nice 1 glad its just about sorted
    hopeyou can fix the loom and not need to buy new.
    #24
  26. _adam_
    Offline

    _adam_ Member

    Joined:
    May 29, 2013
    Messages:
    47
    Likes Received:
    3
    [Jun 22, 2013]
    Scratch that it's not isolated to that door :(

    Carry on head scratching, so lee if you can source a ccm for me to try it would be great😃
    #25
  27. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,800
    Likes Received:
    499
    [Jun 22, 2013]
    ill get onto it sfter the weekend
    #26

Share This Page