1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

loads of warning lights and no speedo on 2.4 c6 what could it be

Discussion in 'A6/S6/Allroad forum (C6 Chassis)' started by jemis, Jan 18, 2012.

  1. jemis
    Offline

    jemis Member

    Joined:
    Sep 23, 2010
    Messages:
    31
    Likes Received:
    0
    [Jan 18, 2012]
    after having the front wheel bearings chged on my 2005 A6 I now have just about every warning light up on the dash a dodgy handbrake and no speedo, anybody have any idea what went wrong?
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. jemis
    Offline

    jemis Member

    Joined:
    Sep 23, 2010
    Messages:
    31
    Likes Received:
    0
    [Jan 18, 2012]
    would I be on the right track thinking they have broken a sensor or cable to a sensor
    #2
  4. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Jan 21, 2012]
    what warning lights exactly? abs? traction? esp? brake pad wear?

    might have damaged an abs/pad wear sensor.

    speedo is driven off a sensor on the gearbox tho. dunno how they might have managed to damage that changing wheel bearings.

    take it back and complain. get them to code read it etc.
    #3
  5. Colin Allroad TDi
    Offline

    Colin Allroad TDi Member

    Joined:
    Jan 24, 2012
    Messages:
    45
    Likes Received:
    2
    [Jan 25, 2012]
    Damaged speed sendor I would say, not 100% here mind, but ABS, ESP and speedo all rely on the speed sensors for their readings.
    #4

Share This Page