1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Let the troubles begin

Discussion in 'A3/S3 Forum (8L Chassis)' started by Speedy Steve, Jan 3, 2009.

  1. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    [Jan 3, 2009]
    Well its all starting to go wrong wih my S3.

    Firstly the pump went on the central locking and blew a fuse at the same time but know my radio doesnt come on when i start the car or switch off when i take the key out of the ignition but does when i press the power button on the radio.

    Also the interior light doesnt come on when i take the key out but does when i open the door have i missed a fuse or something?

    Im still waiting for my new pump to turn up so could it be that because the centrallocking isnt working that its affected it?

    Before i get flamed for not searching i have looked but everything seems to be related to a replacement of HU but this is the stock double din one

    Please help its bugging the hell out of me ive only had it 6months
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,297
    Likes Received:
    971
    [Jan 3, 2009]
    It would be nice to know what is causing your issues cos my interior light comes on when the key is removed but not when the door is opened! oh and my internl central locking button only works when the engine is off!
    #2
  4. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,597
    Likes Received:
    273
    [Jan 3, 2009]
    I recon you have a fuse gone, hence the radio not working properly, as for the other issues the central locking pump assy has lots of functions including controlling the interior light and such. So any proper investigations cannot easily be done until you have the pump fitted and coded etc
    #3
  5. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    [Jan 3, 2009]
    coded? ok now im confused is it worth me buying vagcom?
    #4
  6. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    [Jan 4, 2009]
    Checked all the fuses in the end of the dash and all were fine are there any other i should try?
    #5
  7. 1wheelonly
    Offline

    1wheelonly cabriolet VCDS Map User

    Joined:
    Oct 14, 2007
    Messages:
    2,060
    Likes Received:
    4
    [Jan 4, 2009]
    have just had pm from you steve.
    no problem mate bring it over and we can plug in with vagcom,have you got your new pump yet?
    if the car needs coding after you fit it then youll have to come round again.
    i dont mind having a look before hand if you like.
    stereo sounds like it needs recoding, had a guy on here had the same with a rns-e unit. recoded it and was fine
    #6
  8. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    [Jan 5, 2009]
    To add the latest in the line last night the radio started showing up Telephone and cutting out the radio and then today it cut out after an hour. Oh the joys
    #7
  9. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    [Jan 12, 2009]
    Well the central locking is now working i bought a pump rebuild kit of ebay for 50 notes and fitted it and am chuffed that i know have central locking. The rebuild kit is the motor and pump part and you just solder the cables to the board went in no problem and worked straight away. i did pressure test the hose's to make sure there was no leak and in the process looked the doors i then shut the boot to find id locked the doors Thank god i had a spare key.

    So know the only thing left is the radio only going on or off by pressing the power button not with the engine being started and going off after an hour. Oh and the interior light not coming on when i take the key out of the ignition. any clues as to what this could be????

    Thanks for the help and advice in advance:anbet:
    #8
  10. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,297
    Likes Received:
    971
    [Jan 12, 2009]
    Glad you got the central locking issue sorted. please re-post on this thread when you work out you interior lighting issue as I also have similar things happening.

    Just out of interest was the pump rebuild kit easy to do as I've heard getting to the pump is a mission?

    thanks,
    #9
  11. Speedy Steve
    Offline

    Speedy Steve Active Member

    Joined:
    Nov 14, 2008
    Messages:
    1,250
    Likes Received:
    8
    [Jan 12, 2009]
    it was a bit of a nightmare to get out but i managed it with out removing the trim all be it was a pain but the smile when it worked was worth it and the savings of course
    #10
  12. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,297
    Likes Received:
    971
    [Jan 12, 2009]
    Yeah I'm all about the savings mate :arco:
    #11

Share This Page