1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LCD dead or not?

Discussion in 'A4/S4 forum(B5 Chassis)' started by smoking_bob, Mar 13, 2012.

  1. smoking_bob
    Offline

    smoking_bob Member

    Joined:
    Sep 25, 2010
    Messages:
    62
    Likes Received:
    0
    hi all,

    well after a disaster of a weekend because i burnt the seat :( , it got worse as the LCD seems to have given up the ghost. but i did just want to check as the Yellow/top part is still working. the red part will not come on, Is it possibly a fuse or am i looking at replacing it?

    Also any ideas on how to get hold of some blue alcantara. i wont be replacing the seat, but i will attempt a fix. Is there any spare on any of the seats, underneath them or anywhere?

    Thanks,

    Bob
    #1
  2. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,521
    Likes Received:
    300
    Sounds like you've turned it off. Press the reset button on the stalk to turn it back on.
    #2
    BigAdy likes this.
  3. smoking_bob
    Offline

    smoking_bob Member

    Joined:
    Sep 25, 2010
    Messages:
    62
    Likes Received:
    0
    Hi Aragorn,

    sorry about the delay in getting abck to you! been a mental few weeks. No the reset button wont work? So i suppose it's either faulty or a fuse! Any way of telling for sure?

    thanks in advance,

    Rob
    #3
  4. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,521
    Likes Received:
    300
    If the yellow bit is working the LCD is fine, you've just turned it off.
    #4
  5. smoking_bob
    Offline

    smoking_bob Member

    Joined:
    Sep 25, 2010
    Messages:
    62
    Likes Received:
    0
    Hi,

    ok, so after realizing i could run the self diags, the red part of the LCD is fine, it runs the self disgs. So i assume the problem in on the stalk. the reset button is dead, or a broken wire. Looks like the steering wheel must come off to have a look see. Anyone ever replace the stalk before!

    Thanks,


    Rob
    #5
  6. audiv6quattro
    Offline

    audiv6quattro Member

    Joined:
    Dec 21, 2010
    Messages:
    392
    Likes Received:
    2
    Hi I changed my indicator stalk the other week it's really easy.
    1st disconnect the battery then take airbag of, two hex screws at the back I think it was, than you need to take the nut of in the centre behind the air bag, then pull wheel forward, don't pull to hard though as there is a wire from wheel to the stalks then you need to take the black plastic surround of to access the stalks, now you can access all the stalks, the whole stalk unit pulls forward just enough to get the stalks out. I'll try and find a link with pics for you
    #6
  7. audiv6quattro
    Offline

    audiv6quattro Member

    Joined:
    Dec 21, 2010
    Messages:
    392
    Likes Received:
    2
    #7
  8. smoking_bob
    Offline

    smoking_bob Member

    Joined:
    Sep 25, 2010
    Messages:
    62
    Likes Received:
    0
    Thats brilliant thanks a million!
    #8
  9. audiv6quattro
    Offline

    audiv6quattro Member

    Joined:
    Dec 21, 2010
    Messages:
    392
    Likes Received:
    2
    No worries mate hope you get it sorted
    #9

Share This Page