1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lateral Acceleration Sensor G200 -ESP Problem fixed :D

Discussion in 'A3/S3 Forum (8L Chassis)' started by S3_DAVE, Oct 18, 2012.

  1. S3_DAVE
    Offline

    S3_DAVE Member

    Joined:
    Jul 19, 2011
    Messages:
    65
    Likes Received:
    25
    [Oct 18, 2012]
    Hi All,


    Just thought I’d create a post as I two have had the dreaded G200 lateral Speed sensor.


    I have a 2001 Facelift Audi S3 AMK Engine.


    First thing I would recommend is one of these:


    VAG DIAGNOSTIC ENGINE AIRBAG ABS SCANNER TOOL VW SEAT SKODA AUDI | eBay

    It has been a life saver and for £35 delivered it is reasonable seeing as you would take it to a garage and pay money each time. (Be warned once you have one you will constantly be plugging it in to make sure there are no hidden error codes )



    I have had this error on my car since I purchased it in April 2010 and as it would only happen on the odd occasion, so took no notice of it.


    I have read through various threads and each has had a different explanation as to what sensor goes where and the need to calibrate and not. So I just thought I would let you know about my experience.


    There are 3 sensors that are linked to the ESP:



    • · Longitudinal this is located behind the passenger glove box.
    • · YAW and Lateral this are both under the steering wheel- it looks like 1 big sensor however they are mounted on top of each other.

    The Lateral sensor is the smaller of the two.


    Please see below for the part number:

    IMG-20120925-00036.jpg Capture.JPG

    I did try the fix (as I was trying to save £160 on a new sensor)

    BLUEVISIONS

    However the same error was coming up. So I bit the bullet and brought a new sensor. Plugged it in and using the VAG scanner (above) erased the fault and it hasn’t come up since.


    Car drives like a dream now.


    Hope this helps.
    #1
  2. Ads

    Ads

    [Nov 26, 2014]

  3. Sam_
    Offline

    Sam_ Down under

    Joined:
    Mar 8, 2011
    Messages:
    2,863
    Likes Received:
    367
    [Oct 18, 2012]
    I had the G200 issue too, bought a new sensor and it turned out that the bracket it's clipped to was bent so not sure the new sensor was actually needed!
    #2
  4. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,793
    Likes Received:
    1,226
    [Oct 18, 2012]
    lateral and longitudinal are also the same sensor.
    #3
  5. Sam_
    Offline

    Sam_ Down under

    Joined:
    Mar 8, 2011
    Messages:
    2,863
    Likes Received:
    367
    [Oct 18, 2012]
    Doesn't that depend on the year? I know some had the combo and some don't or do you mean same part number?
    #4
  6. Rosso TT
    Offline

    Rosso TT Member

    Joined:
    Jun 4, 2011
    Messages:
    146
    Likes Received:
    3
    [Oct 19, 2012]
    I do have this fault and it pops up from time to time ( ESP light remains on till next start up).
    Hate to think what would cost this sensor at local audi dealer here down under.
    #5
  7. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,793
    Likes Received:
    1,226
    [Oct 19, 2012]
    yes same part. theyre just mounted differently
    #6
  8. dre_S3
    Offline

    dre_S3 Member

    Joined:
    Feb 9, 2012
    Messages:
    756
    Likes Received:
    39
    [Oct 19, 2012]
    I got this problem again my abs and ESP light keep coming on fault code is saying longitudinal sensor but not sure where this is behind glove compartment or under my stearing wheel
    #7
  9. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,793
    Likes Received:
    1,226
    [Oct 19, 2012]
    glove box.

    you have vcds? if so you can unplug them and watch the readings for long and lat go mental to confirm which is which. thats how i worked it out
    #8
    S3_DAVE likes this.
  10. S3_DAVE
    Offline

    S3_DAVE Member

    Joined:
    Jul 19, 2011
    Messages:
    65
    Likes Received:
    25
    [Oct 19, 2012]
    Audi charged me £159 with staff discount as one of my mates works for SEAT (mad when you actually see the size of it.)
    #9
  11. S3_DAVE
    Offline

    S3_DAVE Member

    Joined:
    Jul 19, 2011
    Messages:
    65
    Likes Received:
    25
    [Oct 19, 2012]
    That is how i diagnosed the issue, i used my V-GATE scanner (VAG DIAGNOSTIC ENGINE AIRBAG ABS SCANNER TOOL VW SEAT SKODA AUDI | eBay) and did exactly that scanned it, unplugged each sensor until there was no additional error and it confirmed the sensor in question.
    #10
  12. dre_S3
    Offline

    dre_S3 Member

    Joined:
    Feb 9, 2012
    Messages:
    756
    Likes Received:
    39
    [Oct 19, 2012]
    Yeah I think it's £160 for the part, so they fitted it for free really it is a skank for what it is I am debating in getting a second hand one off ebay for around £50 and fitting it myself
    #11
  13. dre_S3
    Offline

    dre_S3 Member

    Joined:
    Feb 9, 2012
    Messages:
    756
    Likes Received:
    39
    [Oct 19, 2012]
    no mate only got one of those £30 vag scanners it lets me clear the fault which is telling me its the sensor but a few days or so later it comes back then goes off again
    #12
  14. Sevv
    Online

    Sevv Pushing the limits..

    Joined:
    Jan 27, 2011
    Messages:
    1,322
    Likes Received:
    116
    [Oct 20, 2012]
    mate Audi qouted me 1300$ to fix or call up awesome gti and you pay 580$ still allot but cheaper then latter


    though you should note that mine is sadly combined
    #13
  15. Sam_
    Offline

    Sam_ Down under

    Joined:
    Mar 8, 2011
    Messages:
    2,863
    Likes Received:
    367
    [Oct 20, 2012]
    Pretty sure I got the sensor from VW (who buys parts from Audi? it's just added markup on the price) and it was $200 or so. Maybe check my thread or I can look through receipts. Piss easy to fit. Literally 15-20 minutes plus calibrating it in VCDS or a liquid gauge.
    #14
  16. Q-spot
    Offline

    Q-spot New Member

    Joined:
    Dec 17, 2011
    Messages:
    16
    Likes Received:
    0
    [Oct 21, 2012]
    Can I ask a question on the ESP as I believe I may have a similar issue.
    My (8L) 2002 A3 1.9 TDI Quattro Sport kicks in the ESP on what I describe as moderate cornering, more noticable when switching direction(fast sweeping roundabouts etc). The dash light comes on and the braking systems does its thing and tries to re-stablise the car, when to be honest it is no where near any loss of grip.
    I've run a full VCDS scan and nothing comes up with regards to fault codes.
    Need to get this sorted as it does scare me to death when committed to a corner and it takes over, I've resorted to turning it off when approaching patches of road I enjoy driving.
    Am going to have to have a look if its a badly posistioned or loosly fitted sensor, but any recommendations would be greatly recieved.
    #15
  17. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    16,305
    Likes Received:
    1,490
    [Oct 21, 2012]
    Is your steering wheel centred when driving in a striaght line or does it sit off to the left or right a bit?

    <tuffty/>
    #16
  18. Dizz
    Offline

    Dizz New Member

    Joined:
    Oct 21, 2012
    Messages:
    9
    Likes Received:
    0
    [Oct 21, 2012]
    Hi guys, first post in a thread that uncovers a problem that I may have haha..I have the ESP fault as well. Intrigued by the centered steering wheel as mine isn't?? But I also have no speedometer reading and Rev counter dies (VSS ordered from Audi stealers).

    Not been scanned yet but will be ordering that scanner tonight. I have numerous issues, Oh the joys!

    Only just bought my A3 and looks like I may be here a lot.
    #17
  19. Sevv
    Online

    Sevv Pushing the limits..

    Joined:
    Jan 27, 2011
    Messages:
    1,322
    Likes Received:
    116
    [Oct 22, 2012]
    i wish i had a dollar for every time you said that Paul, might as-well record it :p
    #18
  20. Q-spot
    Offline

    Q-spot New Member

    Joined:
    Dec 17, 2011
    Messages:
    16
    Likes Received:
    0
    [Oct 22, 2012]
    sits nicely in center. I do have a worn/split rear wishbone bush, wondering if its causing the sensors to see a step change in cars posture, hence engauging safety system?
    #19
  21. mr_jangles
    Offline

    mr_jangles New Member

    Joined:
    Nov 6, 2012
    Messages:
    1
    Likes Received:
    0
    [Nov 6, 2012]
    Where did you get the sensor from and do you have part no. as can't read it from your picture, is it 1J0 907 651A? Did you fit it yourself? Any help is much appreciated. Cheers Matt
    #20

Share This Page