1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Knocking noise after coilover install

Discussion in 'A4/S4 forum(B5 Chassis)' started by eugeneuk, Nov 28, 2012.

  1. eugeneuk
    Offline

    eugeneuk New Member

    Joined:
    Sep 6, 2011
    Messages:
    5
    Likes Received:
    0
    Hello,
    I installed FK AK coilovers on my b5 last week. Since then i've got a knocking noise coming from front at low speed on a little bumps. I also replaced all front suspension (meyle hd kit) about a month ago, so its definitely something with coilovers.
    I will appreciate any help.
    Thanks,
    Eugene.
    #1
  2. Arrkon
    Offline

    Arrkon Midlands regional Moderator

    Joined:
    Oct 8, 2010
    Messages:
    1,695
    Likes Received:
    75
    Only thing that springs to mind (mind the pun), is the top mounts. Were they new or re used from old suspension?
    #2
  3. eugeneuk
    Offline

    eugeneuk New Member

    Joined:
    Sep 6, 2011
    Messages:
    5
    Likes Received:
    0
    Thanks for your reply Arrkon,
    I re-used them, but they seemed fine and I never heard any knocks with the original shocks. I was googlin about this problem for last few hours and found something about brass washers, that should be included in every coilover kit, but I haven't seen any in my kit. Also found a DIY instruction where guy re-used bottom rubber where spring sits in but I haven't done it http://www.audiworld.com/tech/pics/wheel28-front22.jpg . Actually not me, my mate(who works in the garage) did all job but I was there so definitely know what he did :) Could this be the reason?
    #3
  4. Arrkon
    Offline

    Arrkon Midlands regional Moderator

    Joined:
    Oct 8, 2010
    Messages:
    1,695
    Likes Received:
    75
    It could be, Something is definately moving, be that the spring/top mount/bushes.

    Best bet is to take the wheel off and put some load on the spring with a jack or similar and see where there is any play, before throwing parts at it.
    #4
  5. jcb
    Offline

    jcb Active Member

    Joined:
    Sep 19, 2005
    Messages:
    4,118
    Likes Received:
    13
    what car?
    what coils?
    how low?

    pics?
    #5
  6. eugeneuk
    Offline

    eugeneuk New Member

    Joined:
    Sep 6, 2011
    Messages:
    5
    Likes Received:
    0
  7. lawsy
    Offline

    lawsy New Member

    Joined:
    Mar 19, 2013
    Messages:
    7
    Likes Received:
    0
    I'm getting the same with mine

    B6 A4 avante

    ever since fitting the coilies - but only on the front left - the front right seems fine

    I've since taken apart the suspension and fitted new top mounts - still there

    So I then replaced all upper and lower arms, new track rod and C link drop link - its still there - after doing the arms and ball joints its quieter, but still there - only on lower speeds and only on smaller bumps - its driving me insane - makes me hate driving it..

    Has anyone cured it yet - I'm so tempted to bin the coilies (FK Streets) and put on standard shocks with -30mm lowering springs..
    #7
  8. spartacus 68
    Offline

    spartacus 68 Member

    Joined:
    Dec 17, 2008
    Messages:
    261
    Likes Received:
    29
    Check the condition of the ARB rubber bushes.
    #8
  9. lawsy
    Offline

    lawsy New Member

    Joined:
    Mar 19, 2013
    Messages:
    7
    Likes Received:
    0
    which ones - the main ones, or the ones on the drop link?
    #9

Share This Page