1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Knight Rider lights

Discussion in 'A3/S3 Forum (8L Chassis)' started by silver_mase, Oct 13, 2009.

  1. silver_mase
    Offline

    silver_mase New Member

    Joined:
    Sep 28, 2009
    Messages:
    18
    Likes Received:
    1
    [Oct 13, 2009]
    Just wonder if any one els has had this problem? I think it may be down to slightly bad connection on the switch.
    I get home after long day at work, turn lights off, including parking lights, lock the car up and go in the house. In the morning I come out, open my car and as I open the door, the lights on chime sounds??? The switch is still off; the parking light is still off but still the chime sounds. Sometimes, after starting the car, the self diagnostic then says that there is lamp out, but there isn't?

    Any suggestions?

    Thanks.
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,902
    Likes Received:
    1,331
    [Oct 13, 2009]
    Indicator stalk left down or up? Doing this leaves a sidelight on....(typically)

    Check the side lights bulbs too as this sounds related

    <tuffty/>
    #2
  4. silver_mase
    Offline

    silver_mase New Member

    Joined:
    Sep 28, 2009
    Messages:
    18
    Likes Received:
    1
    [Oct 17, 2009]
    Yeah, its not that I have left the indicator stalk down/up, it just comes on by its self. It did it again the other day, just pushing the switch a bit knocks it back off but it requires no human input to come on? Very odd? I checked last time and the side lights were all on. I think it is just a faulty switch, dry solder or something of that ilk.
    Thanks for the suggestion tho.
    #3
  5. Fuzzy felt
    Offline

    Fuzzy felt Member

    Joined:
    Apr 15, 2009
    Messages:
    101
    Likes Received:
    0
    [Oct 18, 2009]
    I had a problem with my fogs coming on when i turned the lights on, i took the switch out and found that the wiring block had come loose on one side, worth a try.
    #4

Share This Page