1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

K03s boost problem

Discussion in 'A3/S3 Forum (8L Chassis)' started by and32, Oct 19, 2009.

  1. and32

    and32 Member

    Joined:
    May 12, 2009
    Messages:
    42
    Likes Received:
    0
    hello ive just had a customcode phae 2 remap on my k03s conversion a3 and i think im having boost problems. the car only makes a spike of about 16 psi at the most, then almost instantly falls to about 14 psi up to about 4500 rpm at the most then it keeps dropping and at 6-7000 its about 8-9 psi, is thiss normal or to low. I keep reading posts bout k03s cars holding 15 -16 psi all the way to the redline.
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Az

    Az Hard slammed!

    Joined:
    Jun 11, 2008
    Messages:
    1,027
    Likes Received:
    34
    I've got exactly the same set up on my A3 mate, same map etc.

    I've got a boost gauge to go in my car which I haven't got round to fitting yet, so unfortunately I can't tell you if boost does drop and by how much, but I can tell you that you should be seeing slightly more boost with that custom code stage 2 map, I think mine peaks at about 18psi iirc. Mine does seem to drop a bit from 6000 rpm, again, couldn't tell you by how much, but that's the nature with most turbos, especially as the k series turbos aren't exactly big! so will naturally run out of puff higher up the rev range.
     

Share This Page