1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

K&N 57S-9500 kitt for audi a3 2010 1.4 TFSI

Discussion in 'A3/S3/Sportback (8P Chassis)' started by lundoz, Dec 30, 2009.

  1. lundoz
    Offline

    lundoz Member

    Joined:
    Dec 21, 2009
    Messages:
    80
    Likes Received:
    0
    Hi!
    I just bough this kit for my audi a3 2010 1.4 tfsi.

    When I putt it all together and tightend the "metal stop ring" the filter just slides back out.

    Do i tighted it do hard or do I need to tighten it as hard as possible?

    Is there somting that could go wrong if its not completly mounted?

    And is is dangerous to drive with the airbox lidd of? The sound is so much better without :)

    Norway:blush:
    #1
  2. Mattfaced
    Offline

    Mattfaced Member

    Joined:
    Dec 8, 2009
    Messages:
    73
    Likes Received:
    0
    Dont drive unless there is filtration!! filter and connection to intake pipe must be tight and have no airleaks if the pipe just slides out then it hasnt been fitted properly
    Last edited: Dec 30, 2009
    #2
  3. lundoz
    Offline

    lundoz Member

    Joined:
    Dec 21, 2009
    Messages:
    80
    Likes Received:
    0
    Thanks for reply mate!

    Right now the airfilter is fitted on and screwed on so when i try to pull it off the airfilter its stuck. I haven't tightend it very hard because every time I tried to do so it just slided off. It seems ok now i hope :)

    But is it not ok to drive with the airbox top off?
    #3
  4. lundoz
    Offline

    lundoz Member

    Joined:
    Dec 21, 2009
    Messages:
    80
    Likes Received:
    0
    I have now tried to tighten the airfilter on very hard but it still keeps sliding out.
    I know its airtight when its just been mounted on and not tightend to hard.

    The sound is just GREAT!! Sounds like a rallycar when i took the topp.
    #4

Share This Page