1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

just had new "rev d" OEM DV fitted

S. May 15, 2010

  1. S.

    S. Save the manuals Team Ibis TFSI Owners Group Audi S3 quattro Manual

    2,028
    553
    113
    hi everyone...two days ago was driving around and i felt a lack of power and a little delay in power delivery. car was quick but not as before, and the intake noise was weird. so yesterday i checked my old OEM DV (06F 145 710 G , thought that i have new one hence my car is Fcelift '09) and i found that was broken. there was a big hole on it. after that i bought a new "rev D" OEM DV (06H 145 710 D) and fitted it. after driving it with the new DV the car felt like it was remaped again!! it pulls stronger than ever did!! there is no delay in power delivery anymore. i've got stage 2 on it for a 4kkm and i think it never felt like that powerfull before!! i'm starting to think that the old one was faulty for a longer time, but not noticeable as two days ago.
    just had to share my immpresion after fitting it, and would like to advise to every one that feels lack of power or a delay in power delivery to check their DV probably it's gone, and change them with the stronger one (rev D or Forge).
    thanks for reading...:beerchug:
     
    s3_trev likes this.
  2. Haz1

    Haz1 Member

    223
    2
    16
    Getting mines fitted today along with RS4 fuel pressure regulator and Denso Iridium IK24 spark plugs, cannae wait now lol!! :jump:
     
  3. jungleman

    jungleman Well-Known Member

    2,035
    42
    48
    ive seen a few people now talk about the rev D dv... how do you know if your old dv is giving up?
     
  4. akash_sky1

    akash_sky1 Active Member

    1,181
    5
    36
    did the same and got the same results. although didn't kno the S3s were similarly affected with their remotely located dv.
     
  5. mrgicm

    mrgicm Phantom black S3/

    137
    0
    16
    Nice to hear that you sorted this problem... :) now its time for rest of the parts to get into game... you are allmost there... congradulations... :)
     
  6. S.

    S. Save the manuals Team Ibis TFSI Owners Group Audi S3 quattro Manual

    2,028
    553
    113
    well...as i said lack of power, delay in power delivery and unusal CAI noise. take it of (on s3 it's located in front of the engine) by unscrewing 3 torx screws holding it and look for the holes in the red rubber. here's a pic of mine broken. it's a big hole :laugh:
    [​IMG]

    i think that both s3 and 2.0t have the same DV. the problem is when your car is remaped you're running higher pressure and that causes DV failture.

    thanks mate, it made a huge difference...yes almost there, just need to sort the hpfp (next week i guess), and twintercooler when it comes and that's it for now...:rock:
     
  7. akash_sky1

    akash_sky1 Active Member

    1,181
    5
    36
    i kno there the same DV, but on the 2.0TFSI its located directly on the turbo which is why they can fail on standard cars also, whereas the S3s is located remotely at the front
     

Share This Page