1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Just changed MAF and now things are worse!

Discussion in 'A3/S3 Forum (8L Chassis)' started by spencerjoel, Jun 22, 2007.

  1. spencerjoel
    Offline

    spencerjoel Member VCDS Map User

    Joined:
    Feb 18, 2004
    Messages:
    78
    Likes Received:
    0
    [Jun 22, 2007]
    Hi guys,
    after my 51 reg 1.9 tdi started to hesitate and lose power when cruising everyone suggested to change the MAF sensor.
    Well, yesterday I did this and instantly the performance was back, brilliant, it was smooth again and the MPG even increased a little. But, after about 1 hour the car hesitated again and then the ESP light came on, and stayed on and after a few more miles it felt as thought the turbo was not working at all, the car was struggling to reach 60! and juddering like mad.

    After pulling over, turning the engine off and restarting again all was well and I thought it was all fine. However the same has happened today again.

    Sorry for the long post but do any of you have any ideas what this may be, changing the MAF has definately helped the original problem and its strange how simpy stoppping and starting the engine cures it.

    Cheers
    #1
  2. Ads

    Ads

    [Sep 18, 2014]

  3. jojo
    Offline

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,184
    Likes Received:
    1,649
    [Jun 22, 2007]
    Sounds like your car is hitting 'limp' mode, where the car will operate in a lower state of tune,minus the turbo, to get you home! I recommend a diagnostic check with vagcom, to see what fault codes come up.
    #2

Share This Page