1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Jubilee Clip

Discussion in 'A3/S3 Forum (8L Chassis)' started by MURRAYS444, Sep 12, 2010.

  1. MURRAYS444
    Offline

    MURRAYS444 Member

    Joined:
    Aug 4, 2009
    Messages:
    790
    Likes Received:
    38
    Really shook up about this, I was driving down the motorway and heard a pop and had no boost all that happened when trying to accelerate I was just getting a whistling noise. I took the next exit and I was starting to fear the worst my mate in the car said it will be the clip from the hose going to the charge pipe coming off and when I checked he was right but the jubilee clip was missing luckily enough there was a B&Q near us and I got a new jubilee clip but does anyone know what silicone pipe I could get to replace the exciting hose as it is located above the belt???
    #1
  2. barters3
    Offline

    barters3 Member

    Joined:
    May 21, 2008
    Messages:
    438
    Likes Received:
    0
    i dont think the hose is generally the weak point. unless its visibly split i would just replace the clip for a decent jubilee or forge item. there are very high performance clips out there but in my opinion if your running a standard engine it would be over kill as they are quite pricey.
    #2
  3. MURRAYS444
    Offline

    MURRAYS444 Member

    Joined:
    Aug 4, 2009
    Messages:
    790
    Likes Received:
    38
    Yeah the same thing happened after I got my car back from Audi :no: was thinking of replacing the hoses for silicone ones but not sure if it would be worth it!
    #3
  4. S3KO4
    Offline

    S3KO4 Member

    Joined:
    Aug 15, 2009
    Messages:
    850
    Likes Received:
    2
    Best to tighten the clips when the hose is warm that way it wont leak, it happened to me yesterday, booting it on third, while a bmw 645ci went past and bang, but I knew it was one of the intercooler hoses, turned out it was the one that goes to the charge pipe on the intercooler side so pushed it back in somehow but couldn't do the clip, just drove home off boost, until this morning I removed the headlight to clean the hose and use a stronger clip. then happy days.
    #4
  5. rossbrownlee
    Offline

    rossbrownlee Ross_S4

    Joined:
    Aug 16, 2009
    Messages:
    719
    Likes Received:
    0
    ScottM4 -

    Which hose was this that popped off mate as there are four connected to the boost pipe? Since you say above the belt I assume it is the hose going from the boost pipe to the offside intercooler?
    Also, if you tighten your clip when everything is warm you will not get the best bite. When warm you are putting a cold hose clamp onto a hot system where everything has expanded (albeit not by much).
    When you turn off everything else is going to contract again as it cools but the hose clamp will not contract as much.
    Make sure and take the hose off where it popped off and clean the mating surfaces carefully making sure to get all oily traces off, use a new clamp and you should be okay mate.
    #5
  6. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,792
    Likes Received:
    1,283
    JCS Hi-Grip clips are one of the best out there... use them all the time and they are the ones Forge supply... sadly they are not cheap in stainless steel but you can tighten them much tighter than std jubilee clips without getting the 'click of death' and they give better feedback as to when they are about to go as tight as you need them than t-bolt clips which will continue to tighten until its cut our hose and pipe in half!

    OEM clips are made of cheese...

    <tuffty/>
    #6
  7. MURRAYS444
    Offline

    MURRAYS444 Member

    Joined:
    Aug 4, 2009
    Messages:
    790
    Likes Received:
    38
    Changed the Clip as soon as it happened tbh but was just worried where the other clip went to just worried it got caught up in the belt the clip I got was out of B&Q I know it sounds a bit DIY but it was at 7:30 0n a sunday night and was the only place open lol!!!
    #7

Share This Page