1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

It stays on !

Discussion in 'A3/S3 Forum (8L Chassis)' started by Buzzer, Nov 27, 2012.

  1. Buzzer
    Offline

    Buzzer Member

    Joined:
    Apr 11, 2011
    Messages:
    410
    Likes Received:
    14
    Car runs perfectly, park up and the radio lights will not turn off, nothing on the display.
    Turned on the ignition, started back up and radio will not work ( still lit up in red)
    Turned the car off and alarmed/locked and still the display is lit up in red. Doubt I'll have
    power in the battery tomorrow.
    Any ideas guys?
    #1
  2. James TQ
    Offline

    James TQ Member

    Joined:
    Apr 20, 2012
    Messages:
    563
    Likes Received:
    7
    Have you got the indicator stalk up/down
    #2
  3. Buzzer
    Offline

    Buzzer Member

    Joined:
    Apr 11, 2011
    Messages:
    410
    Likes Received:
    14
    Yep, tried that, all lights checked etc. defo not that.
    #3
  4. Emmo
    Offline

    Emmo Member

    Joined:
    Apr 7, 2007
    Messages:
    197
    Likes Received:
    2
    Pull the radio fuse, so you dont have a flat battery in the morning!
    #4
  5. Buzzer
    Offline

    Buzzer Member

    Joined:
    Apr 11, 2011
    Messages:
    410
    Likes Received:
    14
    Car was ok this morning! Still the same problem. Anybody else?
    #5
  6. Buzzer
    Offline

    Buzzer Member

    Joined:
    Apr 11, 2011
    Messages:
    410
    Likes Received:
    14
    Sorted! Pulled out fuse 42, cleaned it and put back in, hey presto.
    #6

Share This Page