1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is my TPS screwed, or does the TB need cleaning?

Discussion in 'A3/S3 Forum (8L Chassis)' started by Welly, Oct 15, 2009.

  1. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    Have been having all sorts of odd problems with my 1.8T. Bought VAG COM and a cable to see whats going on and have noticed something a little odd.

    Even when I am giving the car absolute DEATH, VAG COM Block 004 only ever shows the throttle status as 'Part Throttle' when it really isn't. TB Angle claims to be max of 85.1 degree, which seems pretty open to me, so why does it claim that it's on part throttle?

    :wtf:
    #1
  2. Dani_B19
    Offline

    Dani_B19 Audi-sports own special child.

    Joined:
    Nov 9, 2008
    Messages:
    7,275
    Likes Received:
    90
    Have you taken the TB off and inspected it?
    #2
  3. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    No, but I shall be this evening. I only noticed it today and wondered if anyone else had had the same problem....
    #3
  4. jojo
    Offline

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,024
    Likes Received:
    1,594
    Try this, put key to ignition and switch to on, but don't start car up, then step on the throttle all the way down for 5 secs, then release for 5 secs before firing the car up. This apparently reset the parameters of the TB and throttle pedal.
    I have this Intelligent informeter thing which I can plug into the OBDII, and I can see the throttle going from 0-100% on my car.
    #4
  5. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    Shibby, I'll give that a blast. Not sure if that will work since it's an AGU engine which is throttle cable based - but will try it none the less....
    #5
  6. jojo
    Offline

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,024
    Likes Received:
    1,594
    Hmm yes, DBW throttle would help... what was I thinking? lol
    #6
  7. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    OK, TB has come off, been cleaned (looks fine as well, working OK). Reinstalled and re-aligned with VAG COM. Idle was a bit screwed to start with but OK now.

    Same problem.... 85.1/85.5 max TB angle reported and never anything other than Part Throttle shown in the text window.

    Can anyone confirm that AGU engines will actually report something other than 'Part Throttle'? I'm concerned I'm hunting down a problem which doesn't exist...
    #7
  8. b1gdave83
    Offline

    b1gdave83 Member

    Joined:
    Sep 23, 2009
    Messages:
    161
    Likes Received:
    0
    My old AGU 1.8T only ever came up with part throttle, I never did fine out if that was right or not.

    I presume you have checked the cable adjustment?
    #8
  9. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    Yeah, checked the cable, it's opening the TB fully. I looked at the TB when it was off and it's capable of opening to 90 degrees, and does on full throttle - so it seems odd that it claims it's 85.
    #9
  10. ben4866
    Offline

    ben4866 Member

    Joined:
    Oct 23, 2009
    Messages:
    32
    Likes Received:
    0
    Hey Welly did you get your prob sorted ? I too hav same prob with my AGU, only get 83 degrees and only shows part throttle but I havn't started inspecting the problem yet.
    #10
  11. Prawn
    Offline

    Prawn My other car is a MINI!!!!

    Joined:
    Dec 8, 2006
    Messages:
    9,486
    Likes Received:
    1,302
    I'm having this exact same issue at the moment too!!!

    Generally when pressed to the stop the throttle only goes to 84.6 degrees, unless I REALLY press hard into the floor when I get 85.1 degrees like Welly, and the throttle status only ever shows part throttle.

    I can't help thinking the car won't request full boost unless it thinks it's at WOT....

    I tried to realign the TB in vagcom, but it appears that my shareware version doesn't allow me to do it :(
    #11
  12. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    I tried that as well, cleaned, and polished right up to a sheen I might add!! :drool:, then re-aligned with VAGCOM and still only ever get Part Throttle.

    Maybe thats the way it's meant to be? But I can't see it personally. I just couldn't justify the cost of a new TB to test with really.
    #12

Share This Page