1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

is my fuel pump on the way out

Discussion in 'A4/S4 forum(B5 Chassis)' started by graham A4, Apr 14, 2009.

  1. graham A4
    Offline

    graham A4 A4

    Joined:
    Jan 3, 2009
    Messages:
    17
    Likes Received:
    0
    hi all just wondering if any one can advise me on a problem im having. there is some times when i start the car after iv been driving for an hour or so and it struggles to start and then when i accelerate nothing really happens for a while and basically runs dat way for a while. this fault has only occured approx 3 times since having the car which is 9 and 2 of them times were in the last month. any one who has had this problem and can giv me some info would b much appreciated,

    regards graham
    #1
  2. jcb
    Offline

    jcb Active Member

    Joined:
    Sep 19, 2005
    Messages:
    4,118
    Likes Received:
    13
    won't start when hot?
    unlikely to be the fuel pump if it starts OK from cold. fuel pumps on the way out are very noisy (some perfectly good ones are very noisy so not always a great sign!).

    sometimes the cam postion sensor can show symptoms as you describe. My father's car did this. whip off the CPS and give it a wipe, starts every time for about 300-400 miles.

    Best thing you can do is to get it VAGCom'd, the diagnostics will show up any sensor faults and may show up fuelling issues
    #2

Share This Page