1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Irratic Idle - MAP sensor?

StanboA3 Jul 21, 2005

  1. StanboA3

    StanboA3 New Member

    13
    0
    1
    Hi peeps, i've started to notice some irratic idle speeds and every now and then the engine stalls itself (generally when pulling up to the lights etc). Could it be a faulty MAP sesor? If so, are they easy enough to swap out?

    Cheers in advance,

    Ben
     
  2. MikeA3

    MikeA3 Active Member VCDS Map User

    1,178
    1
    38
    Ben,

    Sounds like an interesting problem, it might be worth getting it checked by someone with a VAG cable as they would be able to tell you exactly whats wrong.

    Regarding the MAP sensor - did you mean MAF? - if so, you can clean it first to see if that solves the problem.

    I'm sure it's been covered somewhere on her before, might be worth doing a search
     
  3. StanboA3

    StanboA3 New Member

    13
    0
    1

    Ok MikeA3, thanks for your help. Afetr posting I found out its a MAFI have not a MAP. I'll give it a clean, cheers

    Ben
     
  4. RichA3Turbo

    RichA3Turbo ...Watching you! Staff Member Moderator

    5,089
    5
    38
    Could also be the throttle body actuator. It controls the idle and sometimes when its warn (like mine) it goes back and forth and finally settles...however, it does sometimes stall if you take your foot off too early. I just keep the revs up a bit with my foot and gradually bring it down to idle. A new TB is £190+vat for a cable throttle model.

    RIch
     
  5. Ryanc

    Ryanc Active Member

    1,321
    0
    36
    My Throttle Body ceased/stuck and idle was all over the place when it went wrong.
    A DBW Throttle body is £300+vat from the stealers.
     
  6. darnich

    darnich Member

    106
    0
    16
    You can always try and clean the throttle body with carb cleaner but you then have to perform throttle body calibration...

    Had a similar problem and my mechanic performed the above procedure...TB was foul of oil debry,
    ever since cleaning it I never had idle or stalling problems so far

    Hope that helps
     

Share This Page