1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

iPhone to MMI integration via bluetooth

Discussion in 'In-Car Entertainment' started by razputin, Oct 15, 2009.

  1. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Hi

    I have a 3G iPhone on 3.0 and have the phone paired to my MMI-high in my A6. I thought all the contacts etc would be accessed through the MMI or MFSW but nothing seems to download to the car.

    Am I missing something or is there a newer upgrade for the MMI for better compatibility? If so, how do I check the version I have and how do I uograde?

    Cheers
    #1
  2. s8craig
    Offline

    s8craig Active Member

    Joined:
    Jul 26, 2005
    Messages:
    1,562
    Likes Received:
    5
    Yeah you need to update the MMI software, it will update the phone module and should be fully compatible then.

    Check your MMI, press CAR, then VERSION and read out the top line. The seond group of 4 digits is the version.

    Latest is 5570
    #2
  3. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Can I update this or do I have to go to the stealers? Pricey?
    #3
  4. s8craig
    Offline

    s8craig Active Member

    Joined:
    Jul 26, 2005
    Messages:
    1,562
    Likes Received:
    5
    Update yourself, shouldn't be a problem unless your MMI is very old, but your car is 2006 so should be ok. You will need VAG COM to fix a few probs after the update.

    5570 is 3 CD disks and should be downloadable from the web with a bit of searching.
    #4
  5. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Nice one! I'll give that a try.

    My current software version is 'C6-HU 21.2.0 0534' Presume that means version 2120? seems really out of date to me.

    Can I update straight to the latest 5570 version? Or is there an interim update to do first?

    From reading about how long this process takes can the battery take it or... well...you don't keep the engine running do you?

    Found the 5570 disks easily enough :)
    Last edited: Oct 16, 2009
    #5
  6. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Help!!!!!

    Ran update, well cd1 to begin with and it had an error loading the radio part. Now I get 'radio not installed!' on the mmi screen. Any ideas?

    Not going well at all now! Getting more errors with cd2. 'Error 152 from device'
    Last edited: Oct 17, 2009
    #6
  7. s8craig
    Offline

    s8craig Active Member

    Joined:
    Jul 26, 2005
    Messages:
    1,562
    Likes Received:
    5
    Sounds like your CD changer is broken or you are writing bad CD's.

    I updated an A8 this morning with all 3 disks and no issues.

    It should be possible to recover the radio as long as your media and CD changer are working ok.
    #7
  8. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    I think it must be the cd's. I hope! Going to download them again and try burning them again on better cd's at a slower speed perhaps.

    It's just my luck that it wouldn't work first time!

    Cheers man
    Last edited: Oct 18, 2009
    #8
  9. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Finally getting somewhere with this update!!

    After getting all those errors I got better CD-R's and finally got the radio back!

    Now have issues with Cd2 as it is updating 'handyvorb2' it gets to 99% and comes up 'error 152 from device'. Any ideas? Tried it a few times but no luck!

    Should I give it up and take it to the stealers?
    #9
  10. s8craig
    Offline

    s8craig Active Member

    Joined:
    Jul 26, 2005
    Messages:
    1,562
    Likes Received:
    5
    Unfortunately the handyvorb is the biggest issue, the update could have trashed the module.
    #10
  11. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Module? Does that sound like it may need a piece of hardware replaced?

    Just called Audi Belfast and they told me that they don't carry out the updates. Thought tha was strange!
    Last edited: Oct 19, 2009
    #11
  12. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Any other ideas s8Craig?

    Tried numerous ways but still can't get CD2 to work. Still the same 'error 152'.
    #12
  13. foolish3uk
    Offline

    foolish3uk Member

    Joined:
    Aug 2, 2004
    Messages:
    455
    Likes Received:
    0
    hi there, you should not really have tried it unless you have seen someone else do it first, this could proove to be quite exspensive to put right!

    firstly dont use cdR's to write the programme, use a write once only disc of a high standard, if this does not work you do need to take it to a main dealer and have them do an mmi update which will not be covered under warranty, as long as you have not destroyed the programming of the front display control unit which is the controller for the MOST bus you might be able to get it repaired for about one hours labour, i work at a main dealer and we have stacks of update cd's for all types of engine and mmi systems. i would say there is a 95% chance you have already destroyed your phone control unit. you could try and say that it just failed but you might find that a main dealer cd wont be able to overwrite the damage you may have caused.

    TAKE IT TO YOUR DEALER!
    #13
  14. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    Unfortunately the main dealer in Northern Ireland don't software updates. In fact, they deny they even exist!!

    Only reason i updated was to get better compatibility with my iPhone. I wanted to go to the dealer to begin with but they said it should work fine under SW 2120 and that they can't update the software unless the car had a recall. That got me to here.

    Don't think it's worth playing around with in case I make it worse.

    Just going to bite the bullet and take it to the dealer. I'm sure I won't get much change from £400 though?!

    Heard there is a better spec of module available now, is that true?

    Cheers for the advice by the way :)
    #14
  15. foolish3uk
    Offline

    foolish3uk Member

    Joined:
    Aug 2, 2004
    Messages:
    455
    Likes Received:
    0
    all software updates are availiable to customers if they want to pay for them, new software is not availiable under warranty unless there is a fault though. this main dealer probably has not got their internet software link set up or your talking to the wrong person, we all go to the same college in milton keynes and we all talk from the same rule book so suggest you phone and talk to the master tech, he will normally be able to sort you out!!!
    #15
  16. razputin
    Offline

    razputin Member

    Joined:
    Feb 13, 2005
    Messages:
    73
    Likes Received:
    0
    I got speaking to the master tech when I called my local dealer originally. He was the one who told me that they do not carry out updates nor do they sell the the cd's. They only adjust the software if new parts require it. He argued that my iPhone would work fine with version 2120 and that it didn't need an update to enable the use of the phone list etc. Too late to get him to prove it now with a trashed BT module :(

    I have been offered a few second hand units that may be worth trying first myself. If I was able to get the module replaced with another and it was running an older version of software, would it still work ok? Would it work straight away with the system or would it require some other programming? Not really keen on trying another update on it as you can imagine!
    #16

Share This Page