1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

iPad issue with photo sync from iPhoto

Discussion in 'Home Cinema, Hi-Fi and Gadgets' started by warren_S5, Aug 30, 2011.

  1. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator

    Joined:
    Oct 31, 2007
    Messages:
    7,176
    Likes Received:
    2,358
    Hi all

    If you want a quick answer head down to the header called 'In Summary', if you want to know the detail, keep reading.

    I thought I'd post this on here as I've been going backwards and forwards between the web and Apple Tech guru's and I'd rather save any one else with the same issue a load of trouble like I've had.

    I'm currently running:

    Computer: MacBook Pro 2.4GHz Core 2 Duo 2.4GHz / 4GB DDR2 SDRAM
    O/S: Lion 10.7.1
    Software affected: iPhoto (9.1.5) / iTunes (10.4.1)
    iPad 2 (OS 4.3.5)

    First issue after Lion update was that I noted photos were missing from my iPad that should have been sync'd across (as per my selection in the iTunes sync selection window). After much head scratching I noted anything less that a 4* rating was not pulling across, and this was because my iPhone 4 only copies across photos that are 4* or above (as it only has small memory). Therefore the cache for photos seemed to be doing the same for iPad even though I was selecting everything.

    Anyway a couple of days later I upload some more photos as I start getting an error message saying 'Photos DSC_0001.jpg has not been copied as it is not the correct file format'. At this point I lose my rag and call up Apple and relay all the issues I'm having post Lion. They tell me to reinstall iTunes to see if it remediates the issue.

    At this point I think, I need a bigger HDD, so I buy one and install it then do a clean load of all software. All should be good then. No, same issue comes back (I've done a restore from Time Capsule of all files) :scared2:

    Now I'm ready to bung everything out the window!

    So anyway I do some reading and it turns out that if you go into Finder, and find your iPhoto library, then right click on it you can open up the sub folders and files by clicking on 'Show Package Contents'

    So I do this and then I delete iPod Photo Cache (then delete from recycle bin). I then reopened iPhoto, and resync'd iPad. Still the same issue.

    In the end I (fortunately had all older photos on the SD card still), loaded all photos onto another laptop, renamed them with a batch editor in Picasa, reloaded them onto an external HDD, and reimported them into iPhoto (after deleteing the original ones). It was a pain in the arse at it meant I had to re-face / re-location / re-edit every single bloody photo from the bad post Lion load up (about 550 photos).

    The good news is it worked, and when I then deleted the iPod photo cash AGAIN, and resync'd it then soaked up all the new(missing) photos.

    HOWEVER, the story doesn't end there. I'd loaded a few photos from my iPhone 4, and these got copied across to my iPad before I'd had a chance to edit them. I went back to edit these 12 photos (clean up / crop), and then resync'd the iPad, and the old versions of the photos remained (e.g. the edited versions didn't copy across). I tried deselecting them and reselecting them from sync, and the old originals just returned. So in the end I deleted them from the library, did a new import, re-edited the photos and then sync'd them to iPad and then did a FINAL delete of the iPad photo cache file and then resync'd and voila - all present and correct.

    NO-ONE should have to go through this, it's a bloody shambles, and as no one at Apple seems to understand the implications of a fix I thought I would post it on here in case anyone else suffered similarly. Initially as I have over 12000 photos I thought it may be a volume based issue, or something to do with file sizes (my images are only a max of 5mb per file - JPG compressed files from 18MP CCD).

    In summary

    UNTIL APPLE RESOLVE THE IPOD PHOTO CACHE FILE UPDATE ISSUE WITH THIS VERSION OF THE OS / IPHOTO, IF YOU EDIT YOUR PHOTOS AND PUT THEM ON MOBILE DEVICES I STRONGLY SUGGEST YOU DON'T SYNC THEM TO YOUR DEVICE UNTIL YOU HAVE FINISHED THE EDITING OF ALL PHOTOS AS YOU MAY NOT GET ANYTHING OTHER THAN THE ORIGINAL IMAGE BEING LOADED ACROSS!

    I have sent feedback to Apple as part of their continuous ongoing improvement updates, but it's unlikely we'll see anything fixing this for some months (for those affected).
    #1

Share This Page