1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IOS 7 Problem with MMI Bluetooth Interface

drtav13 Sep 19, 2013

  1. drtav13

    drtav13 Member

    35
    4
    8
    I've upgraded my Iphone 5 to IOS 7 and the Bluetooth interface just stopped working...
    I can still browse my contacts directory and place/answer calls but you can only hear static noise from the speakers.

    Anyone else who has tried the above please confirm if you get the same behavior...

    thanks
     
  2. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,354
    1,720
    113
    1st remove the pairing from either or both devices, shut down the car, startup again & repair/test.

    If no go, then do a complete fresh IOS install, add a contact & test the sync/calls are working again.

    I ran an IOS 7 GM install few days before & didn't have much luck with BT, installed public release version yesterday (which was supposed to be identical to the GM, but wasn't) & fresh install seemed to allow me to see devices again, this was on an I4 btw.
     
  3. drtav13

    drtav13 Member

    35
    4
    8
    I've tried removing the pair and shutting down the car (working in IT is my routine troubleshooting technique for pretty much anything that stops working :p :p :p )

    Sync was working normally no issues there , just audio problem.... i'll try fresh install ... (Also makes sense for IT people) :p :p
    thanks for your reply
     
  4. drtav13

    drtav13 Member

    35
    4
    8
    i've reinstalled ios 7 and started from scratch with a new iphone setup. i still get static noise instead of audio.
    unless someone with the same car/ phone had more luck , i would advise against upgrading to ios 7 for the time being.
     
  5. smudger69

    smudger69 Member

    65
    10
    8
    Just been out and tested it with my i4s with ios7 and no issues.
     
  6. driver_tim

    driver_tim Active Member Team Daytona Audi A3

    321
    86
    28
    Upgraded my iPhone 5 to iOS 7 last night. Not actually tried making a call in the car with it since, however I did use Google Maps navigation this morning, and the directions came through the car speakers fine over Bluetooth.
     
  7. drtav13

    drtav13 Member

    35
    4
    8
    thanks Tim I'll try to use the Bluetooth for music/audio redirection,to see if that works.
    In case you place a call let me know if it works.
     
    b00zehound likes this.
  8. Vertigo1

    Vertigo1 Well-Known Member

    3,483
    636
    113
    FYI, at present you can still go back to iOS6 if you want to. Just download the IPSW file from here then hold the shift key whilst clicking the restore/reset option in iTunes and browse to the file.

    This will only work until Apple stop signing/authenticating iOS6, which could happen at any time.
     
  9. drtav13

    drtav13 Member

    35
    4
    8
    You are absolutely correct , already downgraded... Unfortunately tinyumbrella wont work on iphone 5 so there is a narrow time window in case someone wants to switch back to ios6.
     
  10. stevependleton

    stevependleton New Member

    14
    2
    3
    Upgraded my iPhone 5 last night and noticed that Bluetooth was turned off on the phone after installation and set up. Bluetooth working normally with the phone in the car today. Sorry to hear of your problems drtav13.
     
  11. driver_tim

    driver_tim Active Member Team Daytona Audi A3

    321
    86
    28
    Made a trial call this evening and it was fine. Maybe your car needs a software update to be compatible with iOS 7?
     
  12. cemerson

    cemerson Well-Known Member Team Cosmos quattro Audi A3 S-line owners group TDi DSG

    4,569
    1,171
    113
    It shouldn't need to be 'compatible' with a particular OS - the bluetooth protocols are published standards, which are up to the mobile phone to implement rather than the car, so as long as iOS7 implements them correctly (which is very much NOT a given...) you should have no problem
     
  13. yetirider

    yetirider Active Member

    181
    48
    28
    Not had any issues with my 4S in the A1
     
  14. Vertigo1

    Vertigo1 Well-Known Member

    3,483
    636
    113
    Just put iOS7 on my 4S this afternoon but not re-paired it with the car yet. I don't stream music from it anyway as I have a dedicated iPod touch in there for that.
     
  15. Vertigo1

    Vertigo1 Well-Known Member

    3,483
    636
    113
    Out of interest, have you tried resetting the MMI? Press Menu, the wheel and the top right soft-button together.
     
  16. drtav13

    drtav13 Member

    35
    4
    8
    Unfortunately I wont be able to do more tests , since im back on 6.1.4 . Apple has stopped signing IOS6 ,so in case I go to IOS7 I wont be able to downgrade the phone again.
    On the apple support forum I've found a couple of things to try
    1) reboot both car AND Iphone before trying a new pair
    2) remove apostrophes from the iphone's name . (by default iphones get "yourname's Iphone" which for some reason creates problems in IOS7 and Bluetooth.

    I will try again after Audi's Phone Database has been updated to include IOS7 (currently it's on 6.1.4)
    Audi Datenbank f�r mobile Ger�te

    thanks for your tips guys!
     
    Last edited: Sep 23, 2013

Share This Page