1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Intermittent remote central locking

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by funkyspider, Oct 24, 2010.

  1. funkyspider
    Offline

    funkyspider New Member

    Joined:
    May 26, 2009
    Messages:
    20
    Likes Received:
    0
    2003 A4 Avant TDi

    I have an intermittent issue with the remote central locking. Every now and then it just fails to work. Sometimes putting the key in the ignition fixes it straight away. Sometimes it can take a few goes (I usually just ignore it, use the car as normal locking the doors manually until it mysteriously starts working again).

    I have 2 keys and both seem to be the same, although I've only ever tried the second key when the main one is failing anyway.

    The key always works in the ignition so the car is recognising the immobiliser code on the key (?) it just seems to forget the remote central lock code ?

    initially this would happen once every few months and be fine again as soon as they key as in ignition, but it's far more frequent now. Sometimes the car will lock fine, then fail to unlock a few minutes later. Other times it will have unlocked fine, been driven then refuse to lock straight away when getting out. Then it may work fine for days.

    Any ideas as this is starting to annoy me now. I've got to manually unlock the drivers door, put the ignition key in and turn it to release the tailgate lock to let my dog in.

    Thanks
    Martin.
    #1
  2. simon.m
    Offline

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,745
    Likes Received:
    6
    i have this and when i wiggel the wier blockthat goes into the drivers door it works fine
    #2
  3. Digger1
    Offline

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    1
    Had exactly the same problem,,, put the car on VAG-COM, which showed intermittent fault with both keys plus broken wire in drivers door jam, repaired the wire,, No difference so I replaced the battery in one of the keys despite being told it was fine,, and also the rubber button section that you press to lock-unlock...
    It now works fine,,, all of the time !!! ... I got the rubber button section for the key off the bay for a couple of quid, just need to do the other one now !!!
    #3
  4. PungieEC
    Offline

    PungieEC New Member

    Joined:
    Oct 26, 2010
    Messages:
    2
    Likes Received:
    0
    I have the same problem. Have replaced the remote with a new battery and still no effect. The rubber is still good. I have vag-com and can see that the remote is actually picked up the Central Convenience (46) controller. The remote I'm using is adapted as 2 (Key from adapted position) under Group 7 (Measuring Blocks). And pressing each button on the remote will register under Remote control command either 1,2 or 3.

    I'm wondering if there is a communication problem or lost signal due to a broken wire between the controller and the lock cylinders. Any guess where this central convenience controller is located and where would the harness would follow to any further to look for bad connections on any connector blocks?

    Many thanks.
    #4
  5. PungieEC
    Offline

    PungieEC New Member

    Joined:
    Oct 26, 2010
    Messages:
    2
    Likes Received:
    0
    And suddenly the remote decided to work again. And I wonder for how long againg :eyebrows:
    #5
  6. swarcup
    Offline

    swarcup Well-Known Member

    Joined:
    Sep 9, 2009
    Messages:
    1,287
    Likes Received:
    37
    a new battery cured the same issue for me, when i had my problem the range wasnt very good aswell.New battery and it worked from 30 yards away
    #6
  7. jassoni
    Offline

    jassoni New Member

    Joined:
    Oct 26, 2010
    Messages:
    2
    Likes Received:
    0
    Ive had the same problem with my audi a4 cab 2.4 6speed.. Works intermittantly. Was told by a garage that the module needs replacing.total cost £400.
    #7
  8. Digger1
    Offline

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    1
    I was told the same,,, try the battery and button pad first !!!
    #8
  9. jassoni
    Offline

    jassoni New Member

    Joined:
    Oct 26, 2010
    Messages:
    2
    Likes Received:
    0
    Tried a new battery which was bought from E-bay, will try a new button pad. cheers
    #9

Share This Page