1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Intermittent problem on A4 1.8t sport

A4Paul Apr 10, 2010

  1. A4Paul

    A4Paul Member

    33
    3
    6
    Ive got a a4 1.8t sport and now and again when i turn the key it will fire and die,but if i start it again with some revs its fine.its been suggested its the immobiliser/ignition loom as the key symbol comes up on the dash when it dies.has anynoe else had this problem
    Cheers Paul
     
  2. A4Paul

    A4Paul Member

    33
    3
    6
    Anyone???
     
  3. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    17,775
    674
    113
    The fire-up-and-die is the immobiliser kicking in. The fact it needs revs to start the next time is jsut coincidental if the light is flashing when it cuts out.

    If you read the immo fault codes it might give you an idea what has upset it. The usual cause is the reader coil in the ignition barrel, however i've heard that sometimes the wiring just needs moved around a bit to move it away from sources of interference.
     
  4. A4Paul

    A4Paul Member

    33
    3
    6
    Thanks for that,sounds right what ive been told then
     
  5. mwarrey

    mwarrey Member

    280
    0
    16
    I have this problem on my 1.8T. Its my wifes car and we get this issue maybe once or twice in a week and then nothing for a month or so, sometimes longer.

    Until the weekend this had only happened to me once before. On that occasion I tried the ignition a couple of time, removed the key a few times and sure enough the immobiliser light eventually went off and the car started fine. This weekend had the problem again. I was driving and tried turning ignition on and off etc. as before. My wife insisted that if I just rev the car it would be ok. I let her try and sure enough the immobilser light stayed on, the car stuttered a bit but after revving to between 2-3000 rpm for a few secs, the car then run fine. Every time she says this has worked in the past ?

    I have a new immobilser cable, just not got around to fitting it yet!
     
  6. A4Paul

    A4Paul Member

    33
    3
    6
    Thanks,how much was the cable and was it from a main dealer?
     
  7. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    17,775
    674
    113
    I suspect its a weak signal meaning it takes a few seconds for the ECU to realise the key is there, and disengage the immo. If you rev it, then the engine will still be spinning when the IMMO finally disengages and the engine will "catch".

    Alternatively, stick the key in and turn it to the position just before start, then wait for the immo light to go off before turning the key to start the engine?
     
  8. mwarrey

    mwarrey Member

    280
    0
    16

Share This Page